[New Features] API Connector

Hi everyone - the fix for the breaking OAuth2 bug has been fixed. Please let us know if this is still broken in your apps! Thanks again for your patience.

1 Like

Hi, have parameters been restored for GETs? I can’t see them yet.

should be released shortly!

1 Like

Very nice, was looking for this feature the other day. Thanks!

Hope that helps! :blush:

@j805 www.NoCodeMinute.com

For All Your No-Code Education Needs:

  • One-on-One Tutoring
  • eLearning Hub
  • Video Tutorials
1 Like

Parameters for GET requests has been restored. Thanks!


This is Huge! (for some users at least). I’m so excited, no more work arounds needed!

1 Like

I think I found a bug (and a workaround) but I’m not sure. Details are as follows.

The “body canvas” (i.e., area to enter a Raw post body) is missing if I set up an API call in the following way:

  • Type = POST
  • Data Type = XML
  • Body Type = Raw

The body canvas is just missing in this setup, but all other Data Types show the body canvas.

What I’ve been able to do as a workaround (in case anyone else is trying this) is the following:

  1. Set everything up, as above, but change Data Type to Text.
  2. Initialize Call
  3. Change Data Type back to XML
  4. Re-initialize call.

This has allowed me to bring in XML, so I’m guessing the missing body canvas is a bug?

1 Like

YES :grin:

Looking into this!


Hi Nick. Same issue here with input box not showing up with XML. Any update on this? Submitted bug report #15270. Thanks

Hi - the fix went out yesterday. Please let me know if you are still seeing the buggy behavior.


@nick.carroll is there any way to handle the error message body so it doesn’t show up as JSON and would instead be a list of text or something?

Currently seeing this

Screen Shot 2021-05-21 at 3.42.20 PM

Bug_report Submitted :heavy_check_mark:
@nick.carroll We were getting a bug with our SendGrid API Calls in Backend Workflows. We systematically got the following error in our Log: TEMPORARY_BUG (i.e., Sorry, we ran into a temporary bug and can’t complete your request. We’ll fix it as soon as we can; please try again in a bit!) on every Call.

The worrisome thing about this bug is when the changes to the API Connector were applied our Calls were still Initialized in the editor but didn’t function in Backend Workflows. So the only way we were able to find this problem was from new clients telling us they weren’t receiving our confirmation email.

Do we have to go through all our Initialized Calls to ensure they aren’t broken?

Our fix/temporary fix options are:

  1. Enable both API Connector settings (1-Include errors in response and allow workflow actions to continue/ 2-Capture response headers).
  2. Change the Data type of the Call to Empty

If we do not enable apply one of these options the call can’t be Reinitialized.

FYI these are great changes and we appreciate the improvements that are continually made!

Wonderful news @nick.carroll !!

Great news @nick.carroll ! I have spent weeks trying to find a way to put blank values in API calls, and had to develop a whole intermediary API hosted on Heroku to add “blanks” in the API calls, which all slowed down my app.
Glad I can get rid of that !

1 Like

Nice work! Seems to be squared away.

HI. Is there any plan to return error=true for 500 error codes? Suchas 504 Gateway Tine-out in the event of connection issues? Currently the API connector does not reply an error when this happens.


This is cool! So you can have optional parameters, but what if you want to define the optional data in the JSON body? See example below - this is a Stripe API. Sometimes I want to define Address and sometimes I don’t. How can I make the Address fields optional (i.e. if I don’t define them, then don’t send them in the body)?

Currently, if I define null values for these body parameters, the call succeeds but it sends ‘null’ in as values for address which is not what I want…

Edit: realizing I can do this by moving these params to the ‘add parameter’ and making them querystring params. Would still prefer to do this in the body if possible!

I checked the " Include errors in response and allow workflow actions to continue", but when I try to use it in the workflow, there is no option for “API Call’s error” in the “Result of Step 1’s” :frowning:

Obviously, I am doing something wrong here. Any help is appreciated.

I am using the json response type.

Anything by anyone?