Forum Academy Marketplace Showcase Pricing Features

OAuth2 - Bubble API connector - Native Mobile App - iOS

OAuth2 - Bubble API connector - Native Mobile App - iOS

I’m building a native mobile app. Since it is a native mobile app, I have one page only. All the screens in my app are shown/not shown by selectively showing and hiding groups.

I’m trying to connect (OAuth2) to Uber, am getting the below error.

ERROR

THE BASE REDIRECT URI DOES NOT MATCH THE REQUESTED REDIRECT

  1. Has anyone tried to use the Bubble OAuth2 API for a Native App?

  2. Generally speaking, is there a format / standard for the REDIRECT URL for Bubble? For example, if my app is at myapp.bubbleapps.io, what is redirect URL for the OAuth2.0.

Is it simply myapp.bubbleapps.io or myapp.bubbleapps.io/index or page from where I initiate the OAuth2 process or something else?

Cheers!

Oauth will not work for native yet as our current system doesn’t support page changes. We’ll look st changing that when we’ll work on native stuff.

Ok.

For a normal web application (not native), say I am using the bubble standard OAuth2 API.

What is the logic for the REDIRECT URL the Bubble requests during the OAuth process?

Is it the same web page in Bubble from where the OAuth request is initiated?

Yes, it is the same page (has to as the workflow usually has more actions).

I’m having the exact same problem with uber. I get the following:

This is the page the request comes from:


I’ve entered the same thing in the developers’ dashboard:

In the workflow, when the button is pressed, it’s set to “Signup/Login with a social network”. I’ve chosen the Uber API

This is the same configuration as the AirDev Uber example, but I keep having the same problem.

All help is greatly appreciated.

Hey guys,
Check out the uber widget at widgets.airdev.co
On the top right there’s an instructions button which includes screenshots of the redirect URIs to be setup in the uber developer portal. Feel free to check out the api calls as well.

@scottb50,
You’ll need to put in all combinations of the url in uber similar to the one demonstrated in that screenshot. That should be somewhere around 6-10 redirect URIs I guess.

@gaurav. I can’t thank you enough for your plugin. It’s really helped. You’ve perfectly illustrated my problem. Those URIs are driving me insane. I can’t seem to figure out if the authentication is occurring. And if not, I’m not sure what else in the process to tweak.
Thanks for your help.

1 Like

Update…
I think I’m making progress here. I removed the variables and am no longer getting the error.
Fix: Uber calls for URLs in the Authentication area of the admin and URIs in the documentation.

That’s the good news. Bad news is I’m now getting this auth error.

It doesn’t seem to provide specific problems. Any thoughts?

@scottb50
Can you share an editor ? That should help me take a look

I sent it in a message. Thanks!

[solution] The problem was in the authentication information. It wasn’t being sent in the header, because I didn’t put it there. Imagine that… :grin:
@gaurav the genius saw it and fixed it in two seconds.

1 Like

lol thanks for the kind words @scottb50