Open AI API request working front end but not backend

Hi everyone, would love your help with this issue (kind of new using API connector).

I have a couple simple API calls to open AI that work perfectly fine in the front end (everything JSON safe and also I tested on postman). For efficiency and to free the user from waiting for the API response, I copy the workflows to the backend, but when I trigger them in the front end they get schedule but not performed. Very weird.

I tried using the backend worflows in “bulk” operation in the database manager and they worked fine. The problem is exlcusively when triggered/scheduled in the front end. No authentication is needed nor privacy rules.

I’ve done a bunch of OpenAI api integration with my app.

Couple questions:

  • Are you exceeding the token limit? I’m assuming not given you said that it works when using backend workflows in bulk but just want to check.
  • which model are you using? 3, 3.5 or 4? 4 is super slow and bubble has a 60 time limit on it. I had to set up a webhook on an AWS server so that I don’t get timed out as my AWS server can have whatever timeout limit I want on it.
  • if neither of those are your issue, can you send some screenshots of how you’re triggering from the front end and what your backend workflow looks like?

Thanks for the quick response! The idea of webhooks sounds very worth exploring. Here the answers:

  • Not exceding token limit. The test I’m doing is barely 2K tokens total (prompt + response)
    -I’m using 3.5 for most things + ada 2.0 for embeddings
    -Here is a screenshot of the simplest of WF that’s just an embedding. Working good front end and through bulk operation but just freezing when backend scheduled. Also checked that all parameters are going through just fine :slight_smile:

Thanks again for the help!

And in the logs, can you see the OpenAI action getting triggered and it doesn’t return anything or it’s not getting triggered? Can you send a screenshot of your logs?