Option Set not available as a Field type for new field

Over the past few months I created three Option Sets via the Option sets tab in the Data tab of my app, which I’ve named OS Active View, OS Link Type, and OS Post Status (as shown in the attached image) and created the Options needed for each with no issue.

In the past few months I was also able to create new fields on my various Data types of Field type Option Set, and have been able to choose those three from the available OPTION SETS listed in the Field type dropdown in the Create a new field modal with no issue.

This week, however, I created a fourth Option Set via the Option sets tab in the Data tab of my app, naming this one OS Badge Type, and created the Options needed for it with no issue.

My problem is, this OS Badge Type has not been available in the OPTION SETS list in the dropdown in the Create a new field modal, while the other three are still available to choose. I don’t know if this is a bug, or just me doing something wrong.

I searched the forums and did find a few similar sounding issues and some were indeed bugs, but were apparently resolved months or years ago like this one Options sets not available to be added to the database as a field.

I have tried deleting the missing Option Set via the Option sets tab, and creating it again, but that did not fix anything. I also tried reloading my editor, and this week I also updated Chrome. Can anyone help me diagnose whether this is indeed a bug or not?



Bubble has two databases. One for development and another for the live app.

Perhaps you may have created the 4th options set in one and are looking at the other?

1 Like

Thank you for the help! I was looking in the development database for both, so I don’t think that was it, but looking into your comment seems to have jarred something loose.

I recently started using branches, and they were out of sync with the Main development branch, so I merged them just to be safe, and when I went back to Main, the missing Option set was there!

Seems like it could still be a bug, but I am very happy that I can get back to work. Thanks again!

1 Like

This topic was automatically closed after 14 days. New replies are no longer allowed.