PDF Conjurer (updated free plugin, now saving to database)

No, that’s not the case. I have checked in debugger. Image shows up in debugger. Also, it is option set. Not so much of dynamic data actually.

And I am just testing right now. It is not that in some cases it is not working, and in some it is working.

I just tried with other images. You were right in a way that with other images it is indeed working.

But don’t know why it is not working with this image. Image is very much there. In fact it is the logo of my site and is being used everywhere in full application.

Another issue is that even if the image is not present, plugin should simply move forward by not putting that image? Right now it just gets stuck somewhere. I get no error, no file download prompt.

UPDATE: And now it is failing with other truly dynamic images too. Something is definitely wrong here.

Vinni this is a great plugin, thank you! I just can’t get it to insert more than 1 image whenever I try the PDF doesn’t render

I suggest you to add a pause before you insert that image.

1 Like

Thanks for the tip Edwin

Didn’t help. I am anyway now thinking of giving up and preparing HTML itself for now and then do browser print, as it is to be used by our own operational folks to create pdf profiles to send to customers.

Actually it indeed worked on adding the pause. I had two steps for adding images, and I had added pause only in one of those earlier. Now I added pause in both and it is working.

Thanks for the tip!

Curious to know why it is behaving like that though.

It’s something called “race condition”, will be addressed in the next big update (:

Hi vini, thanks for this amazing plugin, helps me a lot!

I’m just struggling with “Create a table”. I need to do a simple table with 2 columns (as shown in the attached screenshot). All the field that are highlighted in green need to be filled in with data stored in our database but the rest is static.

I don’t get what I should put in the input “First column body” and “Second column body” as I don’t have any “list” to put here.

Hope someone could help?


Capture d’écran 2020-10-05 à 19.43.14|690x217

Hi it’s more about a design issue. Try making a different design and you’ll make it easier.

This worked perfectly thank you

Show us how to solve the problem

Hi Vini! Thank you so much for the cool plugin!
Update: I solved my problem after experimenting and changing the filename of one of the two images I used - it was in Russian letters - I changed it to English ones. Can that be the cause of my problem (I described it below) or it was just magic?

‘I’ve set it up for creating pdf invoices and it all worked very well in dev mode but when I pushed the app to live mode it stopped working and it’s not doing the last step - ‘conjure PDF model’.
What might be the problem? It happened to me before, after which I recreated the whole process again and it started working.’

Thank you in advance for your help!

1 Like

Possibly! I haven’t tested to be sure, but it’s quite possible. Congrats on tinkering and solving it :wink:

1 Like

Hi all! Firstly, great app!
I’m looking to get a bit more control over tables. For instance, adjust the height of the header row or inserting blank rows to give this effect. Also, to have different text styles in different columns, for example the left column to be aligned to the left and all other columns aligned to the right. Has anybody been able to achieve this, either by intention or via a work around?

Many thanks!

Hi! Currently that’s not possible, but in the future I plan on making a more complex and customizable table element.

HI @vini_brito
I have got your plugin working in my app perfectly but then i wrapped the app using nativator.io and this causes a critical error. How can i optimize it for native environment?

It’s likely it won’t work in some or all webview environments, only in full web browsers, since webview environments have less features and some of these are needed for this specific tech to work.
In 2019 I tested in Thunkable and Kodular and their webview components didn’t provided enough features to make the PDF machine work.

Note, it’s not their fault, it’s just that webviews are made to have less resources and be lighter than a full browser. A solution would be generating the PDF’s server side, then it would work in any wrapper for the app, however this plugin doesn’t has server side actions.

The server side actions can be built, but it’s not a trivial work, so I don’t know when I’d get to it, but it’s something I’d like to do someday!

@vini_brito that would be great to have a new version that allows us to include an image inside the table element. It will be great.

Maybe we can create a team to support (pay) some additional functionalities, or you can define a new plus version for your plugin and some of us can pay you in advance for it.
Just a couple of ideas.