Forum Academy Marketplace Showcase Pricing Features

Plugin Announcement: Airtable

image

Apparently it’s impossible to delete or modify data once it’s impossible to satisfy that Record expression.

1 Like

Any update here, I have the same problem

1 Like

@sam8

Hi, if there is a change to Airtable schema ( additional fields) how can this be refreshed in Bubble airtable plug in?

I have tried to reintialize new fields but I still dont see the new fields there . The only way was to completely remove connection to Airtable and add again.

Fire up this thread, @greg11 and put your thoughts there:

1 Like

Hi there,

I have a search field and a list that displays Airtable records based on value contained in the search field and a matching field in Airtable

It works fine when I use a regular text field in Airtable to match against. I have noticed however that Bubble plugin always recognizes formula fields as format “Number”. Even if my formula returns Text and I change the data type to Text in the plugin - it is still not possible to do for example searches on the API <“Name of formula field” contains “Some text to look for”>.

My work around was to link Airtable record to itself via linked field and use a lookup that uses the linked field to show the value from the formula field… Lookup fields shows in Airtable plugin as Text type.

It works, but I think the formula field recognition as Number is a bug. @sam8

Yes I can confirm it happens like that on my side.
There’s are some text fields recognised as Number.


My current issue is that I don’t know how to unlink record without deleting the linked record.
Airtable recommends issuing a PATCH to {"fields": {"Links": null}} .
Or sending an empty array {"fields": {"Links": []}}
I only get linkedField add and I try to send null or [] and it doesn’t work.
Any tips are highly appreciated.

Did anyone every get a reply to this? I’ve currently spent almost an hour searching to find an answer.

SPECIFICALLY… how does one define “Record” when Deleting or Modifying a record?