Plugin Announcement: Rich Text Editor

Hello @sam8 ,

I noticed a bug i think ( not in version 1.0 but in versions 1.1.0 and next), when the auto-binding is activated, you have to paste two time to get the text pasted.


1 Like

Hello @sam8

Another bug, the value of the rich text isn’t always what it’s viewed. So if we save, it’s not the good content saved.


You can test by changing the current element edited.


I am having this issue as well. Images also do not resize, but get cut off when on a smaller screen.

It would be nice to have a character limiter. And even nicer if the countable plugin by @ZeroqodeSupport could work in conjunction with it, so that would require making it recognized as an input or multiline input element.

Also, when using the extend to fit function and the text inputted requires the element to extend, it would be nice to not have an unnecessary scroll bar.

1 Like

Have a look at this: 🖋 Build your own Rich Text Editor [New Plugin]

This and the plugin are absolutely fabulous especially considering the fact that a number of external plugin “developers” offer an equivalent [including myself]… Have done for a while…

I wonder about a couple of things:

  1. has Bubble bothered speaking to any of these “developers”? I.e. With my RTE plugin I have faced a few of the discussed issues, and in fact solved them… I have not been contacted by Bubble, have you?
  2. what motive do I have as a “developer” to work on/with Bubble if my work gets undermined?
  3. following the thinking - if I as a user develop a very popular app [on Bubble], will a copy be made by Bubble?..

I sort of anticipated this happening but I still trusted Bubble would speak to plugin “developers” beforehand…


P.S. that “Announcement” on being able to upload up to 5GB isn’t new either…

@emmanuel @sam8 @allenyang

Rich text editor was previously available this is just a replacement.

Really, we shouldn’t have to pay for this basic functionality or be tied to a plugin vendor for a text editor. Your plugin offers something different for those willing to pay

Bubble can do what they like because you are bound to their terms, bound to their platform and bound to their hosting. This is what most forget, you don’t own the Bubble code, you may own the plugin code but it’s pretty useless without the Bubble platform.


I have a few issues with this plugin at the moment.

  1. When autobinding is active and someone is editing a rich text field, the cursor gets moved to the end of the text if the user pauses and autobind saves the field.
  2. Lists don’t format neatly. The second line of text doesn’t align with the text above, but with the number or bullet point.
  3. There is an extra space added above a list. If you have a blank line between a paragraph and a list in the editor, the saved rich text will have an extra blank line.

@eli This indeed works. It shouldn’t be needed. It violates the entire principle of modularizing a solution with reusable components. To make a popup inside of a reusable element work correctly, I had to place a dummy RTE on each page that uses the reusable element.

It is truly a shame, to have to hack and develop in equal measures to get a working solution.

1 Like

Is it possible to limit the size of the images added in the rich text input?

Or to make sure that they don’t take up to much space when I display the input from the rich text input?

This is awesome by the way!

1 Like

Hi @kristerbagnkop! If you click on the image in question, you should be able to resize the image to whatever size you want! Let me know if that helps. :slight_smile:

Hey @sam8,

That works to a certain degree, but I would like to ensure that the users who are publishing a new post using this editor, can’t break the layout of the site as in this screenshot.

Also it would be awesome if the size of that image could be responsive, so it fits the container its sitting within. Does that make sense? see these two screenshots. The image stays the same size while I would like it to be larger on desktop, just like the text field is resized.

Mobile version to the right

Desktop version

Thanks again! Really excited about hopefully launching this on our site soon



@sam8 I managed to fix it with a little CSS:

If anyone else faces this issue:

set an ID attribute to the post body element.
Add a HTML element on the page and add styling:

#yourbodyelement img { max-width: 100%; }

I am having another issue however, that now my body text floats into my footer the first time you load the site. If you refresh it does not happen anymore.


Been wrestling with this for too long.

So it is as if the text element does not dynamically adjust it’s height on the first load. On page refresh it does it correctly.

See the screenshots below:

1 Like

@sam8 Can you guys please look at #1 on this list? It is driving my users mad that the cursor gets moved every time autobind saves the text.

@sam8 @allenyang

I am not sure if this is a bug or expected behavior. I just started to get focused on building a blog for SEO purposes. I was hoping to make it real simple and use this RTE plugin to get the H1, H2, and H3 tags on my page.

My first test of saving data from the RTE into my D.B. shows the following output

Screen Shot 2020-05-08 at 1.59.30 PM

What seems to happen is the designated H3 gets saved as an H1 and the designated H4 gets saved as an H2.

Another issue I ran into is the lack of any H tags getting registered. I tested the site using basic browser inspection tools and had no results for any H tags being present on the page. I then tested using a site another user posted in another forum post regarding the use of H1 and H2 tags with the basic text element in bubble. This is the site

and this is the forum post here

I tested on this site using just the content from the D.B. saved using the RTE in a basic text element and the results showed no H tags at all.

I then tested again on this site, but this time I added a single text element and set it to be an H1

When testing on the site, it showed the use of one H1 tag, which seems correct as I only placed one on the page.

Is the RTE supposed to be capable of producing H tags for recognition for SEO purposes? If it is, something seems to be not working properly, although I am just a beginner with all this, I can’t really tell if that is the case or not but the simple tests seem to indicate it is.


Sorry for the delay here folks - in general bug reports will get eyes on something a bit faster :slight_smile:

I can’t repro the autobinding cursor movement bug you’re reporting…Sam did push some changes last week, so if it’s still occurring for you, please file a bug (same with the other items you reported before).

@boston85719 Interesting observation - I don’t believe this was in our original plan. Will check with Sam to make sure, but this may be more of a feature request.

1 Like

It still moves the cursor. I’ve sent a bug report. Also, what about the formatting issues?

Thanks Allen. I just got an email from Eve that states

Please do note that the H1/H2/etc header settings in our RTE are for formatting purposes only, and are not the equivalent of an < h1> < / h1 > HTML tag set.

That solves the issue for me and now can proceed with developing the blog portion of the app.

I see what you mean by #2; the bug here in my view is more that the indentation in the RTE isn’t the same as the output created by that RTE. I’ll record this one as a bug.

I’m not reproducing your #3, so please file a bug report if you’d like us to investigate further