Plugin in need of a JS library but won't fetch the function

Hi everyone,
I’ve been trying to sort that problem myself for a while without any success despite all the very valuable solutions provided on this forum.
Here’s the problem:

I’m creating a plugin for Web3Auth and use this as the login method for my app. I’m trying to do this on the Solana network (that’s where the problem is).
The documentation for the service is here Integrate Web3Auth with the Solana Blockchain in Javascript | Documentation | Web3Auth

Like most services, it requires external libraries to work and that’s usually not a problem since i managed to make it work for another network (Polygon).
Here are the required libraries and modules required :slight_smile:

I’m using script tags in the shared header of the plugin with jsdeliver link to the libraries. This worked for past plugins/apps and even for the previous network that required the web3auth library, ethers.js and web3.js.

The problem comes with the new library related to the solana network called @web3auth/solana-provider and the SolanaWallet module used here in my code in the initialize field of my element:

I get the error “Uncaught ReferenceError: SolanaWallet is not defined” at every attempt.

I have used different URLs, CDNs, versions and also tried @aaronsheldon’s method referenced here with the same result every time.

I am not a developer so I may be doing something very wrong but since it worked on a different network I assumed it would work again :slight_smile:
Thanks for the help !!