Forum Academy Marketplace Showcase Pricing Features

Prevent API call caching?

Hi all, I have an external API call that I’m calling in a backend workflow.

When I initialise the call in the Bubble API connector, it works correctly and when I check the 3rd party API provider, their dashboard shows the call has run at that point.

However, when I run the workflow, the calls are not running, even though the results of the call (in this case screenshots) are being saved to the Bubble database.

It seems that Bubble is somehow caching the calls, so that when I run them I am not getting new data.

I read on the Bubble forums that Bubble caches API calls by default so I’m wondering if this is the issue.

Does anyone know a way around this as I need to ensure that every API call in the workflow is actually run and not cached ?

Thanks,
Anthony

1 Like

@anthony.hull

Is the app on a paid plan?

Include a randomly generated string or current datetime up to second so bubble sees it as a new unique call.

Thanks guys for replying!

I found the problem was actually the API service I was calling. They were using CloudFlare to cache the results of the API call (in this case a generated image). I had to use a certain parameter on the call to force the cache to be disabled.

@dehacked79 thank you - I did already try that previously which is why I was still confused as to why it wasn’t working, but yes you are correct in terms of forcing Bubble not to cache the requests. In this case though, it was the 3rd party API that was caching. The logs helped me diagnose the issue by looking at the HTTP response of the API call and noticing a cache “hit” from cloudflare.

1 Like