Problem with logging in the App

Hi,

Wanted to see if anyone is having the same issue and can offer a solution.

I’ve recently started a new App by coping from an existing App that I have. I copied everything to the new App, including the database content.

However, when I tried logging into the new App, I am experiencing an issue that I don’t experience with my old App.

I’ve taken a video of the problem here: 2022-03-10_12-28-02

But let me try to describe it…

I’ve designed the App so that a User must have his email confirmed before being able to log in. So I have configured two separate login workflows, one with the condition that the User’s email confirmed is “yes”, and the other when the User’s email confirmed is “no”.


If we look at my User thing, you’ll find I have two users, “simon.wong@fundkernel.com” and “jenny.ng@fundkernel.com”. For both of these things, their “email_confirmed” is marked as “yes”.

However, when I try to login with “simon.wong@fundkernel.com”, the App keeps redirecting me to the Email Not Confirmed page, which should only happen if the User’s email_confirmed is “no”.

I’ve tried to following to troubleshoot this problem:

  • Clean out the browser cookies
  • Delete the workflow and re-do it
  • Manually change and saving the the User’s email_confirmed status

But none of it works.

The Editor didn’t highlight to me any issue with the page. So now I’m at a loss.

Again, check out the link to video screen shot above to see the full flow, but I’m wondering if anyone else had such an issue in the past.

Thanks,

FundKernel Development

This is very strange…

Disable both workflows to a test…
Try to create a text field to display Current Users’ email_confirmed status in the index and see it’s value after the login…

Is there a reason you are doing a search for users vs just current user, email_confirmed is (yes or no)?

Right now it look like you are just getting the yes or no of the first user in your database, not user that just logged in

1 Like

I suppose he is searching for the user with the provided e-mail (that is why he is using :first item).

You are correct @rpetribu .

I’ve contacted Bubble support for this and they don’t seem to know what’s going on either.

What is even weirder now is that I tried deleting one of the users and re-registered it. And I uncovered that even the Email Confirmation is not working.

I’ve taken another video of it here: 2022-03-11_13-21-29

Hummm…

What is going on in your “E-mail confirmation page” ???
Can you share with us the workflows in this page???

What catch my attention regarding this last video (and I may be wrong) is that Bubble’s native e-mail confirmation system changes the “email confirmed” field. It is a native field that we can’t see or change.

image

In your database, you have a column named “email_confirmed”, what means that you are creating another confirmation email system (am I right?). Note that in your database there is an underline between the words.

image

That is why is important to see what is going on in this “email confirmation page”.

It is faster than any other solution :rofl:

1 Like

Please to Debug with Step by Step, maybe there are some events getting triggered. You can check also in the server logs

Hi @loulouaying1204 ,

Thanks for responding.

Unfortunately, in this case the debugger won’t help because when I click on the email confirmation link on the email, the debugger doesn’t open. I am guessing because I am opening the app from a link on an external application (Gmail).

if you’re using the same browser with the a tab that bubble editor open you can add the debug_mode=true in the URL to enable the debugger

Hi @loulouaying1204

Thank you for your suggestion of using the Debugger.

Hi Ranne,

I’ve found something really interesting about the email confirmed login problem.

I ran the Debugger set it to Step-by-Step and found something really interesting…

Apparently, there seems to be something “broken” in the search command “:first item” in which it didn’t return the desired result, which caused the search result to be incorrect.

Here’s a detail video: 2022-03-12_10-52-18

I think this may be a bug at Bubble?

can you please check the table privacy

1 Like

Here it is…

See anything off?

that’s exactly the reason why it’s not properly working, please check the email in the everyone else section or just check the view all fields and find in the searches item

1 Like

Hi @loulouaying1204 ,

I’ve checked “View all fields” in the everyone else section as you’ve suggested…but that didn’t fix the problem

Any other thoughts?

please include this

1 Like

HooYah!

I think that did it! Now the login seems to work properly. The debugger seems to be reflecting the right workflow!

Thank you very much @loulouaying1204 ! You’re life saver!

that’s great to hear

1 Like

Hi, for my part the confirmation works, I put a field in my header which stipulates if the mail user is confirmed and indeed after registration without logging out, I clicked on the confirmation link in my mailbox and the status has changed to “confirmed” but after disconnecting then reconnecting it no longer works, the debugger indicates that the status of the email is unconfirmed when trying to connect…