Repeating group does not show on phone (iphone)

I have a simple repeating group and it does show on the desktop but not on the phone (iphone). I have tried all kind of things down to just creating a page with a simple repeating group and no other elements. Same thing: shows on the desktop but not on the phone (tried with Safari, Chrome and Firefox).
The page is set-up for mobile and all other elements show on the page. The repeating group’s background is there, so it’s on the page, but it shows no elements nor dividing lines of the repeating group.
At this stage, it feels like a bug in Bubble. Hopefully, it is not.
Grateful for any help!

Hi @daranyi :slight_smile: Welcome to the Forum! And hmm, that’s odd! Do you have any hiding rules or conditional statements on the elements in the repeating group? If not, can you temporarily set the app to public and share a link to the app editor? (You can temporarily set it to public by going to Settings --> General --> Application Rights: Everyone can view or edit, then copy+paste the editor’s URL into a new forum reply here)

One of the key things to remember is that you have two different databases with your Bubble application: one of your test (development) environment and one for your live environment. It’s an easy thing to mix up when you’re getting started. This video will explain things a bit further.

When you’re working directly in the Bubble editor and hit preview, it links you into your development environment. You can tell that you’re in the development environment because the URL will include /version-test (ex.

If that isn’t the issue, feel free to share a link to your app editor here or in a PM and I’ll take a look.


@dan1 That was it! Thank you so much!
Indeed, I was playing with the development version on the desktop and the live version on the phone. It is “funny” though that the repeating group (in this case) does not get displayed correctly, not even non-data elements like a rectangle inside it. But I guess this is because if the data is nil then the repeating group is not being populated.
Thank you again!

Not to worry, still catches me every so often when I’m in the thick of testing.

As well, sharing one of my LearnTo lessons here on How to Implement Zero Count logic. (ie. when there’s no data to display, having a bit of context for the user).

1 Like