Forum Academy Marketplace Showcase Pricing Features

Repeating group only showing one line

Hi there!

I am trying to make an app and have found this excellent tutorial:

However, I have followed it twice now from start to finish doing exactly what she does and on both occasions, when doing the repeating group, it shows exactly as she has done it before hitting preview (44minute mark on the video for reference), but when clicking preview on the search page it is only showing one line. So there is no repeating group nor can I scroll through the users. I have created multiple entries on the account so that there should be a list, and the users created show in the database. However, for some reason mine will only show one individual and not a list.

I can’t progress without this and it’s really frustrating! Any help is appreciated!

Thank you in advance!

As the link isn’t showing, the YouTube video is called:

In-Depth Tutorial: How to Build ANY Type of App Without Code on Bubble. By 'Coaching No Code Apps.


Hey Jak! Welcome to Bubble!

Can you show us some screenshots of the issue you’re having so we can try to diagnose the issue? :slight_smile:

Hi there, @jakkellymusic… the issue is likely related to a privacy rule on your User data type, probably something like This User is Current User. If you remove that rule (you can always add rules later), you should see all of the data.



Hi there Mike, thank you for the quick reply!

Can you tell me where I can find that setting to see if that is the issue?

Kind regards!

Sure… go to the Data >> Privacy tab, and click on the User data type.

1 Like

So it’s indeed showing that Mike. Am I pressing the bin icon on the right despite it having the ‘find this in searches’ box ticked it should still work?


1 Like

With that rule in place, the current user can only find their own user in searches. As I mentioned, you can delete the rule (yes, the bin icon) to see if that is causing the issue (I’m just about certain it is) or you can go to the everyone else section (which is directly below what you are showing in your screenshot) and allow everyone else to find users in searches and view all fields.

Oh, and you should definitely take the time to research and read up on privacy rules… it will be time well spent for sure.


Mike you are the best, that’s sorted the issue out!

Getting all these replies in less than 30 minutes from posting is incredible.

Thank you!

1 Like

Mike. Cool! Solved my problem. Thanks a lot!

1 Like

This topic was automatically closed after 70 days. New replies are no longer allowed.