Save a (temporary) url as file and save to bubble record


Using the api to merge pdf documents that are in bubble. I’m getting back a temporary url as shown below. Is there a way to save the linked file to bubble? I’ve tried everything I could think of. It needs to be a part of the same workflow that merges the files.

Thanks for nay help offered,


1 Like

In API Connector, did you set the file field to “file” type?
If yes, you can use :saved to S3 and the file will be saved to Bubble.

1 Like

Well I’m using a plugin so that option isn’t available. Great idea. Let me try just using the api. Thanks for your help! I’ll report back my results.

Didn’t know there was a plugin for But if this is the case, the plugin author probably did a bad job on that setting and you can reach to him to update that.
However, is pretty easy to create in API Connector

(Just checked, and it’s that did their own plugin and they probably don’t know how Bubble work :wink: )

1 Like

Hi @Jici

Yes the API was easy to set up but I get the same result.

And the following workflow

results in the same temporary url. told me that all their merged files have that temporary url. So far they haven’t answered my question how to get around that.

Any other ideas?

Remove 's url at the end of expression and select :saved to s3 in the package file field. Be sure thisfield is also of type file

1 Like

not sure I know how to do that.

Exactly like I said. Change package file field in your action to result of step1 merge pdf:saved to s3

1 Like

LOL. OK, so I’d tried that and it gave me the same result. However when I did I didn’t want to change the file name so I left that blank. When I tried it again after you suggested it I entered a test file name and that WORKED!!!

It’s simple once you learn how. :wink: Thanks for your help!!

1 Like

Hello @Jici

I just thought it was working. The url I end up is something like:

So if I start out with:

And merge as we described above I get the url:

You’ll notice that it doesn’t have the .pdf extension.

That’s fine if I download each link manually.

But if I zip the file(s) they come out like this:
I’ve tried every one of zipping plugins. All provide the same results.

Now the computer doesn’t know what type of file it is.

Any idea what’s going on?

When you set the filename in :saved to s3, did you include the .pdf?

In JS Zip plugin, you can have a different field for the URL and one for the File name (from what I remember in your screenshot)

Hello again @Jici ,

I did not.

I just changed it to

Apparently it didn’t like that either because this is what I got:

I finally got it figured out. What you said finally clicked.

I had to use the file rename field and add .pdf. Now it’s working like it should.

Thanks again!

1 Like