Scheduled workflow 1 hour too late (with database trigger)

Hello Bubblers,
Here is my problem…

I schedule an api workflow au 10am (I am in belgium, winter time)
In the logs, the workflow is scheduled at 11am. (probably beacause of my winter time)
And here, the workflow doesn’t trigger at 10am because of this.

BUT : this only happens with database trigger. If I do it with a workflow that trigger an API workflow I do not have the problem.

I knows this only happens a few days per year, but now it a a real problem, my reminder arrive 1 hour too late.

Has someone an answer to this problem ?

Thank you for your help, have a nice day.


Hello @serge

Everything that happens in the Backend Workflow is in UTC time. Normally Bubble calculates if it is a time change and adjusts accordingly. So there are two parameters to take into consideration. The TimeZone of your region and DayLight (± 1 hour).

1 Like

Thank you @JohnMark .

As it seens not easy at all, I managed to resolve my problem (for the moment) with a normal workflow.

The thing is that it is linked to users push notifications (and I do not know the time zone of the user).

Thank you for your kind reply, have a nice day.

1 Like

Yes, it is horrible.

If you look in settings/versions there is an experimental way to allow back end workflows to take on another timezone. This may well work with database triggers.

i.e. you could set it to be the timezone of the user who created the trigger in the first place.