Set state on element from workflow

Is anyone else having trouble getting a workflow to set an element’s state? I have tried creating new test workflows, using new elements, new states, and everything short of testing in a fresh application installation. Something as simple as creating a simple “test” button, adding a workflow that sets a custom state of one element with the input of another element does not seem to trigger that action.

In case someone is already wondering, other workflow actions seem to be working correctly. As a matter of fact, on the same test workflow where I attempt to set the state of an element I have added a subsequent action that hides the element (or other elements if I indicate as such). That action works fine even AFTER the failed “set state of element” action in the same workflow.

Debugger does not report any problems. I have tried it in Chrome, in Microsoft Edge, in incognito mode, after using Bubble’s “optimize application” function, after clearing all cookies and cache, and after a well balanced breakfast.

I am attaching a screenshot of Devtool errors I get in both Edge and Chrome consoles. I don’t have any extensions enabled, and like I said I tried testing without my antivirus enabled as well. Ideas?

Hi @destryhunt.dh,

I just did a quick test and had no problem setting a custom state of type “text” to the value of an input. Do you have any plugins installed? Have the tried previewing the page with plugins disabled?

1 Like

@sudsy any way you want to share that setup?

1 Like

@destryhunt.dh this is how to run with no plugins, btw - I had trouble the first time. Long-click preview, then select no community plugin.


1 Like

So, I removed all but the handful of plugins I absolutely need and that are currently in use–then I previewed in “safe mode”. That did not solve it. I cleared my cookies and cache again, restarted my browser, and then attempted both safe mode options. Still unsuccessful. The element I am attempting to pass data from is text, as is the state and receiving element. I do not get any “Bubble” errors. The state workflow fires, because it shows in the log, but the state does not update the element it is intended to update.

I am attaching some debugger screenshots, along with the part of the url that shows I am in safe mode.test 3 test 1

Yeah, I first tried the “no community plugin” view, which yielded no change. I had the same luck trying “no community plugin and HTML”.

I would be happy to share the setup. What is the best way for me to do that?

You can set your app to “anyone can view” in Settings>general and publish the link. Alternatively, someone might accept a dm with the link if you don’t want to publish it. I am not your man today, but maybe someone can chip in.

Your setup seems free of custom code though, this is just Bubble doing it’s thing and it should update the values correctly.

Your devtools seem to have trouble extracting a part of js.min, not setting the state. I’m not sure what you’re struggling with here anymore. Go into your app with the url querystring ?debug_mode=true and inspect the element that is supposed to hold the state. I don’t think you’re having issues setting it that way…

1 Like

Ok…I will see how to give others access. I may do it on an individual basis if someone requests it. I do think that the devtools error has something to do with the problem. I have inspected the element holding the element with debug on and Bubble does not recognize any issues. That is the strange part about this. Bubble thinks everything is fine, although that is clearly not the case.

It’s obvious there’s no issue with Bubble here. You haven’t shown your workflows. You haven’t even told us the value you expect to see in the custom state. You’re confused.

This topic was automatically closed after 14 days. New replies are no longer allowed.