Sheety plugin - post to Google sheet - not working!

Hi there,

I’ve tried to configure a API plugin to update a new row on a google sheet from bubble.
Trying to use the Sheety API - based on this youtube video tutorial from @TipLister (

Video is clear and followed the steps but when I go to create the workflow it wont let me configure the body inputs like in his video (see screenshots below).
Does anyone know what I’m doing wrong?

Really appreciate your help!

![Screenshot 2022-05-03 at 13.49.48|690x183]


hi eissra,
could you provide some screenshots of your setup in your api connector please?

have you initiated the call already?

also, have you enabled the requests on sheety? And connected a googlesheets with the right name, link and name of subsheet (emails) in the video.

Firstly thanks for the video TIpLister - no way I would have gotten to where I am without your help so far!

I’m including some screenshots below - re your questions:
I have enabled the requests on sheety - and when I reinitialize the call it updates my googlesheet correctly (all the right fields in the right columns).

And yes on subsheet - here the sub sheet is 1Workingonit and I have that at the end of the sheety link.

Thanks so much in advance for your time!

ok so when you initialize the call underneath api connector, it works, but then if you use a workflow to add a row to the sheet, on a bubble page, this doesnt work or you cant even find it?
please provide screenshots of a) where you are searching for the workflow and b) if you already have it, the workflow.

Yes thats correct - call works but when i try to use the workflow on a bubble page it doesn’t work. Does not give me the options to link body fields like yours had.

Including screenshots below:

  1. First step in the workflow - basically setting up an event request as a row of data in
  2. Image of the workflow when I select the sheety API I’ve setup(GoogleConnet)
  3. Display of options when I try to add a new plugin action on a workflow (i.e., where I am searching for it) - its called GoogleConnect - 1Workingonit but when I select it - it does not show me any options.

Screenshot 2022-05-03 at 15.20.35

found it.
you got to uncheck private

That worked! Thank you so much - really appreciate you taking the time to help

1 Like

This topic was automatically closed after 70 days. New replies are no longer allowed.