Slow Performance - Sql database plugin

Hi, currently all in Bubble works great for me except when I connect to my database in Azure with the Bubble’s sql database plugin.

Information queries in Azure takes 0:00:00 or 0:00:01 segs, but when I run these querys with Bubble, they take 2 - 3 secs.

Another strange thing that I have noticed, is that the first search takes longer than the second etc. (It seems that bubble takes time to connect to azure, and then there if it generates the query and is no longer delayed).

The editing or inserting stored procedures takes about 5-7 secs the first one, and from then approx 4 secs.

But in Azure the same procedures will take only 0-1 secs or less.

Thanks a lot for your help !!!

May be @emmanuel can help me too :smiley:

Depending on how much data you’re loading this can take a little bit of time as we need to convert it into something Bubble can use. Also, you should check capacity usage, as this processing can consume capacity as well.

Hi, where can i check that?

Also the problem incremented today in an exponential way and time. It’s crazy.

But believe me that is only one row with less than 10 Fields.

It is not too much Information.

In another front this query is fast. I tried to commit to another version and doesnt work.

Im worried to loose all my Job :disappointed_relieved:

This topic was automatically closed after 70 days. New replies are no longer allowed.