Forum Academy Marketplace Showcase Pricing Features

[SOLVED] Braintree - Transaction of decimal numbers

Hey community,

urgent question. I tried to integrate Braintree in my application and it works fine so far. However it does not transfer a decimal amount. When I want to charge 5.99€ it charges 5€. Anybody has an idea why? Do I have to type 5,99€? (Bubble does not accept a comma in the field?). Do I have to change the settings in Braintree somewhere? Anybody with a working Braintree integration with an idea?

Best regards,

Paul

Did you check the server logs to see what was used for the payment?

1 Like

looks like 5.99 was used. Anybody an idea?

What do the log say in Braintree? If there is still an issue please file a bug report.

I dont know where to access the acutal server log. In Braintree the transaction details are stated as followed:


To me the most obvious issue could be the . to , translation. (5.99 <> 5,99). However Bubble does not allow a comma integration in order to test it.

If there is still an issue please file a bug report.

Thanks a lot for solving the issue!

1 Like