Forum Academy Marketplace Showcase Pricing Features

Strange Node Modules Build Error

Morning all! Wondering if anyone else is experiencing a problem like the one below. I thought it was just the specific modules I was using, or my plugin being too big in file-size. I went back into previous plugins where I was able to build node modules and copied their packages, and tried building them in a new app–same error. I’ve reported it to Bubble but haven’t heard back.


Canvas seems to be an issue with NPM as it isn’t loading on runkit either: RunKit

pdfjs-dist seems to be a version issue. Probably something to do with the recent node/package update. But if you use a much older version it builds.

2 Likes

appreciate the help! I’ll give that a shot!!

@bubble.trouble you just saved my day, your suggestions worked. I had to bounce around a couple versions, but ended up getting both to a place that works. Happy to buy you a coffee and a snack if you have venmo/cashapp, just send me your username. My sincerest thanks!

@nicholasrbarrow No problem, glad it worked.

No need to pay for anything, just here trying to help everyone out when I can. If you are really feeling eager you can buy @mikeloc a coffee on my behalf. That guy does a lot more than me for this community!

3 Likes

@mikeloc is a legend. Kudos

1 Like

I’ll do that for sure! Thanks again!