Table filter on dropdown not doing anything?

Hi all! I’ve gone through a number of videos and posts on filtering repeating groups using a dropdown, and for the life of me I cannot get it to work and I’m not sure why. Appreciate any input, I’m sure I’m missing something silly. See below for our situation:

  1. We have a text variable ‘exam_status_display’, as shown here:
  1. To filter on that, we have a dropdown (of Text object type) called “Input Status Filter”

  2. To filter the table, we then apply the following filter:

This does nothing - no matter what you select, everything stays displayed. We also tried intersect with - and that also has no effect:

Also tried contains list - also has no effect

Thanks a ton for any advice, I’m banging my head against the wall on this one!

Full screenshots below for those interested:

Is RCOC/exam_status_display a field on the owner_requirer_join table in Airtable? If so, you can just do Airtable:owner_requirer_join with one of your constraints being RCOC/exam_status_display = Input status filter’s value. No need for an advanced filter

1 Like

Thanks Alex! Tried that as well - see screenshot - unfortunately that doesn’t work either, filter still doesn’t do anything:

can you share a link to your editor?

Hey Alex! Of course, you should be able to view here: RCOC Requirer Portal | Bubble Editor

It’s weird because videos like this one are exactly my use case, and this should work:

but nothing happens, how odd!

Ok I didn’t realize that the dropdown is a multiselect dropdown. Remove the advanced filter and in the search constraints add:

exam_status_display is in Input Status Filter’s Value

Just like the image below but use the operator “is in” instead of contains

You can reference this if you need help:

1 Like

Thanks for the tip! Unfortunately for some reason the “is in” operator isn’t available in the filters:

Could it be because it’s a table, rather than a ‘pure’ RG?

That might be because exam_status_display appears to be of type “list of texts” - could that be it?

To workaround that, I tried the following, but that still doesn’t work:

FYI Since we’re pulling the data from AirTable, and the exam_status_display field is a lookup on another table, that sometimes creates problems because of how it’s ingested into Bubble.

To eliminate that possibility, I created a new field exam_status_text that is not a lookup (it’s local to the relevant table), so it’s just a ‘normal’ text object

Unfortunately, that still has the same problem, no change, except that now it resolves to a text instead of a list of texts, so I can put that in without the advanced filter

It’s same for us. Bubble developers of Airtable plugin broke all filters!!!

@maks2 Sorry to hear that!
All our filters EXCEPT this one work, so I don’t think it’s an AirTable issue in this case, because as noted above I created a normal text field and that still doesn’t work

I mean, for us, it’s like we have a dead simple filter condition to pull only one record that matches. Now it downloads all data from the table. And this is the same for various pages and places in the app.

Another experiment:
Trying to filter by the text itself, not using the dropdown, ALSO doesn’t do anything:

Implication: we know the issue is NOT the dropdown itself

It’s particularly boggling because notice how filters work totally fine for other fields that should be of the same type:

The first two filters in that image work great

Well, either Airtable changed logic of their API causing filters to be ignored or Bubble changed smth underneath in Airtable Plugin causing filters to not be sent.

1 Like

Try reinitializing the airtable tables.

Tried, still the same. And data is pulled fine, just filters are not applying.
And again, we didn’t release anything new to Live for days. How come it suddenly started to ignore all filters?

We also re-initialized, so I don’t think that’s the issue

It’s also curious that all our other filters work, only this new one isn’t working, which makes me think that something about it I’m doing wrong, but the fact that it doesn’t work even with an “Arbitrary Text” value is concerning

Update: I’ve been going back-and-forth with support. First they thought it was an Airtable issue, but I’ve established now that fields created (in Bubble) prior to 1-2 months ago are still working, but IDENTICAL filters with new fields created today do not work, see images:

SOLVED - this turned out to be MY error:

  • I was applying the filter in the table correctly
  • BUT I forget that I also had conditionals on the table to provide sorting, and so each of those conditionals had to apply the filter as well, and I forgot to add the filter to those!

Huge thanks to Bubble support for working with me to figure that out!

Thanks to everyone for your help; hope this flag helps someone in the future!