Forum Academy Marketplace Showcase Pricing Features

The API call returns a non-object and you picked JSON

Hi guys,

I’m trying to use the “API connector” plugin, but it returns the error below:

I’m using these settings in the plugin:

I call the API through this link: https://api.bcb.gov.br/dados/serie/bcdata.sgs.22940/dados?formato=json&dataInicial=01/01/2010&dataFinal=31/12/2016

Which returns me a string of objects, just like the example below:

What can I be doing to resolve this issue?

Add an header
key: User-Agent
value: bubble/yourapp
(You can enter what you want in value).

1 Like

that works! I was having this issue recently, turned to postman and saw that header!

2 Likes

Thank you so much guys! Now it’s working. @Jici @jared.gibb

2 Likes

Hi there
Im having the same issue
i followed your advices @Jici @jared.gibb
but impossible for me the data, the call is not working
see the set up attached
Am i missing something ?
thanks


Are you able to get your api calls working in postman?

I did this (see attached)
but not sure to have more informaiton ^^

ok. click the headers tab here. there may be special headers there.
does the call work from within postman?

What I think you have is a bug in Bubble. you have probably deleted or modify an header and in some case, this will create an issue. Can you start from a fresh new API Call to see if you have this error back?

1 Like

@jared.gibb @Jici
thank you for your replies
I tried a call again
now the issue is not the same but still a problem ^^


Change your data type to the appropriate response? Maybe it’s not a json?

Try text

1 Like

You are calling Integromat and by default, Integromat will return a text. You need to change to text OR add Webhook response in your Integromat scenario

Thanks i will try guys
I guess I will check on thursday.
Not sure BTW that with the text format I can get the right datas
I ll let you know
Many thanks !

@Jici @jared.gibb Ok it works when i turn it into text.
However, it’s not ideal to manipulate datas with integromat as text but i will figure out a solution.
Many thanks for your help !

Can you share screenshot of your integromat scenario?

Yes :wink:
I did a split function, and it works, since it cut differents emails adress

looks like you’re using it as a trigger to send emails? What would you expect it to return?

1 Like