Timestamp Jan 18th 1970

Hi there,

I’m having trouble to convert a timestamp to a date formatted like 6/21/2018.

The Text recognise the data received from an API call as a timestamp but in the RG always displays Jan 18th 1970:

Anyone can help?

Thanks a lot.

Anyone can give me a hand, please?

Thanks in advance

Its likely that the API is returning seconds instead of milliseconds?

Thanks for the reply @mishav

That’s correct, the timestamp is in senconds (1499806103) and apparently Bubble needs it in millisenconds (1499806103000), but I can’t change it. If I could multiply it by 1000 (what I can’t), Bubble then doesn’t recognise it as a date.

What do you recommend?

Thanks very much

You can try this API:


There’s a plugin in the store, Search Unix.

Thanks very much for your help, @vincent56 @yusaney1

@yusaney1I installed the Unix Converter but I must be doing something wrong as it doesn’t show me anything. I’ve even tried instroducing the timestamp myself (1499806103) and nothing, no result in the repeating group:


Thanks very much again.

@vincent56 Regarding your suggestion, I used it but it don’t recognise the result as a json but a text, so the result comes with “quotes”.


Sorry just saw you simply needed to format the date not convert. Yusaneys suggestion is the way to go then!


Wow, that worked!!

Thanks very much, @yusaney1!

1 Like

@yusaney1 can you revise your calculation to take into account timezone offset?

1 Like

This topic was automatically closed after 70 days. New replies are no longer allowed.