Transactions from payment not writing to database

Having resolved one problem after what seemed a lifetime I’ve straight away hit another snag.

I click buy now button, which then initiates the workflow below. The purchase goes through fine, and appears in stripe as a subscription, however the workflow doesn’t create the new subscription information in the database.

That then stops the other steps in the workflow from running.

The user clicking the buy now button will already be a subscriber with an active subscription. The buy now button is for a second subscription (different product to the first).

Any ideas on what is causing this? It was working, and now it doesn’t. Starting to feel like everything I resolve breaks something else and now just going round in circles

I’ve got no idea why it’s not working (maybe check your server logs to see if that sheds any light)…

But, personally I’d always recommend doing this type of thing on the backend, with a webhook - for this very reason…

The last thing you want is successful payments going through that aren’t being registered in your database, and relying on front-end workflows for this is not a good idea (in my opinion).

But, in any case, check your sever logs to see if there are any issues you can see there.

Hi Adam.

I do have webhook on backend workflows. My other subscriptions run and store in the database as normal. This one won’t. Well it did, until I done the API post for clicksend earlier on today

I tried using debugger but when it goes into stripe payment screen the debugger breaks. I am checking server logs now

What do the server logs show is happening?

This is what it shows

I meant for the on-page workflow (the one that’s not working), not the webhook…

I tried using debugger but when it goes into stripe payment screen the debugger stops. Is that what you mean.

This stuff is doing my brain in. I’ve just subscribed again as a new user and now come to see that the stripe webhook isn’t working now either. Everything keeps breaking even when i’m not doing anything with that part of the app

No, I meant check the sever logs to see what’s happening when the ‘Button Buy Now is Clicked’ workflow is running.

Alternatively, check your Stripe account logs to see if there’s a problem on that side.

Do you mean this? This is all it returns when i click the buy now button, it seems none of the other steps in the workflow runs except the first step, subscribe the user.

There’s nothing in the logs for the next step at all?

That’s strange…

My guess would be that something went wrong in the Stripe call, causing the rest of the workflow to fail…

Have you checked your Stripe developer logs?

This topic was automatically closed after 70 days. New replies are no longer allowed.