Unable to load the application data — is it me or bubble?

I’m new to bubble, so not sure if this is something I’m doing wrong or a bubble issue (status.bubble.is reports no outages or problems, hence my post), but I’m having a very hard time previewing changes. The admin interface works fine, but when I try to preview my dev site I’m getting the following error 90% of the time:

“Your browser was unable to load the application data. We’ve been notified of the issue. Please try again in a few moments and make sure not to use ad-blockers.”

I’ve confirmed ad-blockers are not a problem, and it will usually come up after refreshing 5-10 times, but I usually can’t click a link to another page without receiving the same error message.


my app keeps having issues loading the page too… it just started about a few hours ago… getting white pages over and over… have to hit refresh many times to get the page to finally load


Thanks for letting me know, the status page must not be accurate. I’m going to try again tomorrow, as it’s pretty tough to work in this state.

1 Like

Also I’ve noticed that some of my workflow steps are missing.

I sure hope I can get those back, because I put in months of work into building flows.

1 Like

Okey so it’s not just me, i’ve been having the same issue for the last hour, very hard to progress indeed.


Yah I am having this issue too. After trying to preview or even live -version of Bubble.is apps my browser (Chrome) gives next:

“Your browser was unable to load the application data. We’ve been notified of the issue. Please try again in few moments and makse sure not to use ad-blockers”.

About Ad-Blockers I dont use and also nothing I have touched since yesterday.
So issue is from Bubble -side and status page is not responding this.

1 Like

Yep I’m experiencing the same. The backend is working for me fine, however front end previews are displaying:

It occasionally works…


1 Like

Same thing here :frowning:


Same :-/


Same with me too…

1 Like

confirmed - same in the UK and USA.

1 Like

Same here, but periodically I can get it to load. It just loaded, but took some time as if it was loading the app for the first time.

Yup, same here.

@emmanuel Same here. Using the plugin ‘Auto Refresh’. For last 12 hours now.

1 Like

I’ve just added more units with a boost and it seems to have resolved the issue at least in the short term. Might be worth giving it a spin and seeing if anybody else sees an improvement in lease this starts to narrow it down

Forgot to mention, also tried html and plugin free version - stumbled upon the same issue.


Same here…


We’re looking into this and thanks for the bug reports.

Thanks for the reply. For the record, I just started working again about 30 min ago and so far haven’t run into any additional issues.

status page for yesterday says ‘no incidents reported’ - this in incorrect. When will this be updated? I am currently undergoing client due-diligence, I/they need to be certain full transparency with respect to issues.