Forum Academy Marketplace Showcase Pricing Features

Use domain with www

Hello everybody, am new to Bubble. So far good going :slight_smile:

I have added my custom domain to the public app. However, am not able to get the site working on www. and it is always redirected to non-www domain.

Example: Let’s assume my custom domain is www.gooogle.com; Bubble only accepts gooogle.com in the settings area and automatically redirects www.gooogle.com to gooogle.com.

Now, how is that I have gooogle.com redirected to www.gooogle.com?

Any help in this regard is much appreciated. Thank you :slight_smile:

On your DNS settings at your host, you need to set an A record for www that points to the bubble ip.

Below is what it looks like for my domain using Azure as my domain management.

You should also have the standard wildcard A record for the domain that also points to bubble.

Note: Depending on your provider, the wildcard name may be different, or blank. On Azure it is ‘@’.

I’m having the same trouble with my domain.

Using DNSMadeEasy.com. See screenshot below for setting. Doesn’t make sense why it’s redirect to meetaway.com and not stay at www.meetaway.com given these settings. Seems like there’s something odd going on the Bubble side. Anyone else running into this?

Side note - DNSMadeEasy.com won’t accept “@” as the name.

I have added the A record for www to point bubble.

So, when I visit www.mydomain.com, it gets redirected to mydomain.com

But, I want to use www.mydomain.com as primary domain and have mydomain.com redirected to www.mydomain.com

How to achieve this? Please help.

By default, Bubble redirect www.example.com to example.com

This is not something we can change quickly.

1 Like

Aahh! Ok. Thanks @emmanuel look forward to have this feature working sooner :slight_smile:

2 Likes

Okay. Thanks for the lightning quick reply.

This topic was automatically closed after 70 days. New replies are no longer allowed.