UTC Time Plugin Missing?

Isn’t there any plugin that allows you to set time via UTC only? Seems to be missing?

Don’t confuse constructing a date with formatting a date. You can format a date in UTC natively in Bubble (:format as… select timezone using static timezone UTC [or any UTC equivalent]).

NOW, if you’re trying to trick the user into selecting a date in UTC, that’s a slightly different issue.

But a date, once constructed, is just a date and it is the same for all users everywhere, regardless of how you present it to (format it for) the user.

1 Like

In Amateur radio we are concerned specifically with UTC time. That said, it would be great if the app understood what the users local time was and behind the scenes adjusted for UTC time. That way the user doesn’t need to do any math in their head and accurate times are reported.

Your app does understand the user’s local time. And, in fact, that’s all it understands. Did you watch my video that fast (or perhaps you’ve seen it before)? Watch again and listen as I explain how your web browser understands what time it is…

1 Like

You don’t need to do any manipulation. If you use date time picker, user will select according to own timezone and Bubble will save in UTC. When you will display it, il will also display it in current user timezone.
So for example, I’m in EST, I select 22-03-2020 18h00, Bubble save it as UTC, and if you are in CST, This will display 22-03-2020 17h00

Thank you guys for responding!

I got it partially working now, I think. Just that time isn’t being reported?

Any ideas what I’m doing wrong?

Thank you!


date UTC

Format your date to show the time part (edit: I should have said “time of day” part, but I think you get my drift). You’re formatting your date as text such that the time part is hidden. Select Custom and look at all the options you have… customize from there based on the tokens you see. (Experiment!)

I was able to change the settings so that UTC times now appears in the database but that means I lose date. Apparently, time and date together is not an option that can be selected as indicated by the attached pictures.

UTC time 2

Getting closer.

Used the custom setting



Thanks guys for your help on this one!

This was a fun one to solve!


1 Like

You are becoming a Time Lord! :smiley::+1:

Thanks! There is just so much to learn and figure out and understand… When time isn’t on your side it can be very frustrating.

1 Like

I think actually you are saving your date in a text field. This mean that the date will be in the format And timezone where it was recorded and displayed the same in all tz

1 Like

As @Jici recommends: save Dates as Dates. Again, do not be confused about date construction versus date formatting.

(If you don’t know what I‘m on about… watch my video AGAIN, until you do.)

1 Like