Workflow in Debugger (step-py-step) work but normaly (run) not

I have a work flow in one popupwindow and after click “submit btn” is the flow this:

first create a think in "table A (app data) " and with “submit btn” is made changes in “table B (app data)” but

when i run the workflow with debugger step by step the changes are made imediently .

when i run the workflow live the is dont made imediently only when i run the workflow again.

thank you for help

1 Like

PLSSSSSSS Help

This is probably related to the workflow steps firing in order when using Step by Syep, and simultaneously when running in realtime. If you have steps that require data created or changed in previous steps, make sure you reference (thing changed in step 2), etc so knows to wait for thay thing to change.

@msgiblin thank you for the answer the issue is that i dont make changes in the same database table for the reason i cannot use (thing changed in step)

1 Like

If you built these out as custom events, you may have a bit more control over the sync. From another post a couple years back, there’s some great info in here.