Forum Documentation Showcase Pricing Learn more

Zeroqode "AWS file uploader - any size" issue

All of a sudden I get this…
The plugin AWS File uploader - Any File Size / action Get all files from s3 a S3 Objects threw the following error: Cannot read property ‘then’ of undefined

List still loads fine so I’m not sure what happened? Was toying with file type limits but it happens even when I reverted the restrictions. Interestingly everything still loads fine?

Any advice?

Zeroqode support is faster at ZeroQode Forum

Next time, you can also use a trigger like @zeroqode

Thanks @JohnMark for pinging us :slight_smile:

@dehacked79 are you on the latest version of the plugin? If not please upgrade, refresh the page and give it another try

Please support us with a retweet

Levon Terteryan
Founder @ Zeroqode

zeroqode-for-web-160x120
Bubble Templates
Zeroqode Blocks
Bubble Plugins
Bubble Courses
Convert Web to iOS & Android
No-code Development Services

1 Like

Yes I’m on the newest version. Managed to resolve the issue by cutting the S3 Objects item and pasting it somewhere else on the page.

hi @levon , I’m having issues with the aws uploader plugin when I upload images. in a cellphone.

The first one is that the crop function makes very slow the upload (it seems that it doesn’t resize the image).

The second one is, when I upload an image that must been resized (3 mb for example),
the image loaded vertically, does not stay vertically, it loaded horizontally. (But when is a small image for example 100 kb it uploads it ok). This issue is on cellphone and pc.

I will really appreciate your collaboration

@juancamilovasquezard we’ll check this out, thanks!

Hello @juancamilovasquezard
Thanks for patience.

We pushed an update with the following:
Images auto-rotate with the right position, faster cropping process, faster images processing.
Please upgrade to latest version, refresh the app and give a try!
Thanks.

KR,
Zeroqode Team.

Thanks !! I will do it now !!!

Hi, I give it a try:

The image processing and upload is faster.

but doesn’t works the autorotate in cellphones (I chrome with iphone). (When you open the url, the picture was uploaded horizontal not vertical)

The crop function I think is a liitle bit complicated, and the upload still very slow (may be it doesn’t compress the image).

The autorotate works with the crop funciont, but users will hate to spend so many time uploading the image.

Thanks !!!

Hello!

Thanks for feedback, we’ll check this out and an update on the matter.

Zeroqode Team.

Hello @juancamilovasquezard
we have pushed this update to the plugin:
Improvement - image auto rotate when EXIF data is not read correctly. Faster cropping images.
please upgrade to the latest version, refresh the editor and give it a try
Thanks!

thank you ! I will try it ! :smiley:

hi @levon,
I tried, and still doesn’t works the autorotate in cellphones (I use chrome with an iphone XS).

When you open the url, the picture was uploaded horizontal not vertical.

descarga

The upload with the crop function still very slow ( because it doesn’t compress the image, it saves it with a png size of 4mb, and without the crop function it saves in a jpg 186 kb).

The autorotate works with the crop funciont, but users will hate to spend so many time uploading the image.

Thanks !

Hi @levon, I found another bug since the 1.28.0 version, that doest doesn’t allow to upload pdf and shows this error:

<?xml version="1.0" encoding="UTF-8"?>

InvalidAccessKeyIdThe AWS Access Key Id you provided does not exist in our records.undefinedB370EE1B0ADCBD6ACJ1U9kQlKcfImU4hKF97BlsrIeklGSfUyjWURS7Q/YmYeSRxm49ofUzlYxeqx2cbkAebbvC6bkM=

In this video you can see how I upload an image with no problems but the pdf shows an error:

"
https://www.dropbox.com/s/39izbk28reucjxw/Grabación%20de%20pantalla%202019-08-22%20a%20la(s)%208.04.00%20p.%20m..mov?dl=0

"

So I think that I’ts not problem of my credentiales, because I can upload images, and also If I revert the plugin version to the 1.27 version, I can upload pfd without problems.

Thanks

Hello,
we have tested this and couldn’t reproduce.
Our developer suggests to remove the plugin element from the page and then put it back again. Sometimes code updates do not initialize correctly in Bubble so this trick might help
Please try and let us know
Thanks!

Hi, I did it in a new page, uninstalling the plugin, and putting a new fileuploader in a new page but the errors persists in a cellphone. If you do it in a pc it works great. The problem is with cellphones.

Hello @juancamilovasquezard

Let us check this more thoroughly, and be back with an update on the matter. Thanks for understanding.

@juancamilovasquezard Hi!

We pushed an update for the plugin. Please upgrade to latest version, place the element, refresh the app and give another try.
Thanks for patience.

KR,
Zeroqode Team.