Forum Academy Marketplace Showcase Pricing Features

Addtoany social share doesn't work on mobile web

Hi,
Addtoany social share buttons work just fine in Safari on macbook desktop, but when i try them on the iPhone Safari, they all redirect to bubble.is. Any guesses?

Thanks guys!

I’ll check, but if the issue is on mobile with Addtoany, it’s more on their side than Bubble’s

Addtoany buttons are often block by add blockers also. Be careful.

Thanks, guys. What’s best practice for social sharing on bubble, other than addtoany?

You’ll find here how I did :

I know it’s a bit tricky but when you’re refferal is important like for me, you’ve to go throught.

Another advice, the URL in the HTML which redirect to the sharing pages of facebook, twitter and such should not contain the facebook.com, twitter.com domains. So I used TinyUrl to hide them into.

Come back to me if something is not clear.

Just in case anyone still has issues with not being able to use Addtoany to share on their mobile site/app (still doesn’t work for me) I figured I’d share a great solution. Takes a little extra manual work to set up, but it gets the job done.

I’ve created a page in the forum_app named “sharing_buttons” if you need the resource. Each button is set to share Bubble’s homepage by default: https://bubble.io/page?type=page&name=sharing_buttons&id=forum_app&tab=tabs-1

Run mode version to test on your phone: https://bubble.io/site/forum_app/version-test/sharing_buttons

Hope this helps someone! Let me know if you have any questions!

6 Likes

does anybody know how to set the photo that the share buttons use? ive tried the add to any plugin and the suggestions above( on desktop). the bubble.is samples show a snapshot of bubbles homepage. mine just shows a blank page with title and URL. any ideas? thanks!

Yes, it is in settings. Under Meta data. That is where you set the sharing URL, text and photo.

For Facebook you might need to use the FB Linter to refresh the cache. It tends not to check the page everytime.

1 Like

sweet! thank you so much! everything works but on the facebook open graph debugger i get this one error message,

“fb:app_id hasn’t been included in the meta tags. Specify the app ID so that stories shared to Facebook will be properly attributed to the app. Alternatively, app_id can be set in url when open the share dialog. Otherwise, the default app id( 966242223397117 ) will be assigned.”

where do i get my app id? and where do i put it? is this a facebook side thing or a bubble side thing?

App ids come from Facebook, but I dont think there is a place on bubble to put it.

It is a fairly new thing. Facebook happily chnage stuff and break everyone else … Because they are Facebook !

1 Like

There is one, if you use the Facebook plugin. Otherwise we don’t use the app Id currently.

2 Likes

Oh yes. I addded an appid and re-linted. Error gone.

Although the share is still the same.

1 Like

Thanks guys! Everything’s working now

2 Likes