After Apr 4 2022 app update some information is not fetched from database

Hi, I have a form that the user has to fill in before posting it. It has drop down field set up as such:

And a user may select from drop down menu:

That information is displayed in Product page:

User sees the following:

All other fields work just fine and they are set up the same way. Although “Truck Type” field has issues to fetch the data from database.

Now, my database looks as follows: I have a Bids data type that has a field “truck type”

I also set up Truck Type data type as follows:

Appreciate if you could help me with that. I need “Truck Type” to fetch the data from database and upon posting the contract, display that data on “Product page” in that particular field.

Other fields set up the same way and do not cause any issue.

Thank you!

The Truck Type field on the Bid datatype is a text. So it’s not connected in any direct way to the Truck Type datatype.

Perhaps, you’re intending to set the text field on the bid datatype to the truck type’s name (Truck Type) - although that seems a bit illogical.

If that’s the case, then I’m guessing you’re not setting the truck type text field on the bid correctly. You haven’t shown any screenshots of your Bid data, but I’m guessing the truck type text fields are empty.

But… I doubt that’s what you’re trying to do anyway… I would assume that you’re really trying to connect the truck type datatype to the bid datatype…

In which case you need to get rid of the truck type text field on the bid datatype and replace it with a truck type field.

Then make sure you’re connecting the two datatypes with whatever workflow you need to run to do it.

Then you’ll need to refer to the current page bid’s truck type’s Truck Type in your text element.

Have you used your “inspect” tool when viewing this page? The debugger can likely get you to an answer. If that field where you want “truck type” is empty, then you can trace it back. It seems to me that perhaps when the user is hitting “submit” that the truck type is not being written to its respective bid field?

Those text dropdowns can be finicky, especially when you are coding in your own static choices, which you are not, but still the issue could likely be in the step where the data is written. Once you have confirmed that the user form submission correctly writes the truck type into the “bid” database (go into a bid and confirm that a truck type exists in a bid), then you can confirm that the issue is happening somewhere in the fetching sequence or else it is privacy related.

My best bet though is its a privacy rules issue. Could you please share a shot of your privacy settings for the “bid” and “truck type” databases? That might help us move in the correct direction.

Hi @JakeAtAstonish. Thank you for your feedback. Yes, you are right that “truck type” is empty. I checked that the truck type is not being written to its respective bid field.

Here are the privacy settings for the “bid” and “truck type” databases.

Thank you!

Thanks @adamhholmes!!!

I just followed your directions and set up database as follows:

I tried to create new contract and post it. The problem seems still persist as the truck type is not being written to its respective bid field.

And my logic on Product page looks like as follows:

What am I doing wrong?

Okay interesting, so the field is not populating at all. Heres a test you could try:

In the “Bids” database, add a new privacy rule. It will look something like this (I mocked up a quick database):

I have done the following:

  • created a “Bid” database with a “truckType” variable of type “truckType” (hang with me)
  • added a new privacy rule to that “bid” database, named “testTruckType”
  • Added a rule stating when current user is logged in (pretty basic but it will suffice for these purposes. You could also add something like when current user’s approvedBidderField is yes, indicating the user must be an approved bidder to change/write these data items, you get the point.)
  • I have “allowed autobinding” on the data variable “truck type”

Note: You will have the option to allow autobinding on all of the variables in the bid database. For testing purposes, you can allow autobinding for all of them, and if that fixes your issue, I recommend going in and disabling autobinding for fields you do not want the “current user” to be able to change. Be very intentional with privacy rules. My solution is a shotgun approach to figuring out if this is a privacy issue or not.

I occasionally run into this problem, and the autobinding feature sometimes causes unexpected behavior. If this fixes your issue, then you will know it is a privacy issue, if it does not, then we can trace it back to your “submit” function when the data is written.

Hope this helps!

One this relating to your flows is that you might need to change that statement from Current Page Bid’s truck type’s Truck Type by appending on something such as:

  • Current Page Bid’s truck type’s Truck Type*'s value***
  • Current Page Bid’s truck type’s Truck Type formatted as text
  • etc.

What am I doing wrong?

Without seeing your workflows it’s impossible to say, but you must be missing something, or doing something wrong, in whatever workflow you’re using to set the data.

Feel free to post some screenshots and I’m sure someone will be able to identify where you’re going wrong.

Thank you @JakeAtAstonish .

I did the same but still no luck. What else we can do to find out the issue? Any chance I can call support line?

Ok, I fixed it. You gave me right direction to look at the workflow. Thank you so much!!!

1 Like