Airtable Plugin - No schema was returned [error]

Hi. I posted this elsewhere but seems to have been deleted.

I’m super, super, super excited for the new Airtable plugin. Yet, I cannot seem to get it past this error message. I’m a long-time Airtable user so very familiar with their APIs. New to Bubble. I’ve entered, re-entered, checked, and triple-cheecked my keys and table names. There is plenty of data in the tables, and I’ve tried this on more than one base / table.


Am I missing something simple?

Ok, definitely a bug.

This seems to be a problem for any table names that have a space in them. Something Airtable allows. Those tables that do not have spaces in their names seem to connect fine. I don’t see anything in the docs about table name spaces.

I’ve tried working around this by inserting %20 or _ or - instead of the space, but those aren’t cutting it.

Appreciate any thoughts / advice!

So, naturally… I renamed all of my tables to not have spaces.

Sadly, after uninstalling and reinstalling the plugin (it remembered my settings, BTW) the only ones that connect are the ones that were no-space before. It doesn’t seem to be picking up the changes I made to the table names.

I’m not sure if this is a cacheing issue on the Bubble side or what, but the failures seem to pop up very quickly (seemingly without a hit to the Airtable API). I’ve been trying to get this to “reset” and work for ~15 minutes or so.

Thanks again!

Done, thanks @lantzgould

Adding more context for the submitted bug report.

While my first base seems to follow the “if it had spaces throw an error” scenario, I Just tried to connect to another base with a table that has no spaces in the name. Same error.

After trying to connect to nearly every table in 2 bases, it seems that the space in the table name problem still probably applies. But, it appears there may be something else underlying that’s also causing some weirdness for some tables without spaces in the name.

I thought it might be column names (maybe with the primary column), but am not seeing a corollary there. At least nothing obvious to me.

Hi there! Sorry you’re still having trouble with this. I’ve been looking into the issues you’ve been seeing. We have tested for space characters on both fields names and table names with success on both sides. Are these brand-new tables in Airtable, or do you have several rows of existing data for these tables?

If you would like, I could try initializing the table from your application if you send me a link to your editor. It might be easier for me to debug if I can check on exactly what’s happening behind the scenes.

The solution, per support, was to make sure that you have at least one view within your table named “Grid view” (note the case!) There’s a better solution coming, but that’s the work-around for now.

Hi, I have a view named Grid view, yet still can’t seem to initialize a table. I am still getting the same the “no schema” error. Was there anything else you did? I’m at a loss. Thanks

I’ve already seen some updates to the product today (i.e. you can pick a View now). Maybe re-try?

Hi @doublejay,

Does the table you’re trying to connect have existing data? If not, you will need to add at least one record to your Airtable table before it will properly initialize in Bubble.

Besides that, I suggest double checking that your API Key, Table name, Base ID, and View name are correct. If they are, but you’re still having trouble, please file a ticket with support here and we will troubleshoot further.

This topic was automatically closed after 14 days. New replies are no longer allowed.