Airtable - Table Schema not working

When Reinitializing my table the values don’t update. IE the default for “city, state” is “number” and I want to change it to “text”. The reinitialization won’t take effect. Also, I tried removing the plugin and trying everything again and that didn’t work either. Any advice?

What do you mean the reinitialization won’t take effect?

Bubble isn’t perfect at determining the type of field that it is. You simply change it, make sure all your fields are set (or ignored) and then save it.

What part isn’t working? Please be specific.

Thanks for responding!
I can’t make any changes to the Table Schema, even to ignore a field.

I will give an example.

In my Table Schema, “City, State” is a formula in my Airtable database that combines the City and State fields. I’d like to change “City, State” in the Table Schema to “text”.

When I change it in the image shown, and hit “Reinitialize” on the plugin page nothing changes.

Hope this helps!

I’m still not sure I follow.

  1. The first thing you will do is click the REINITIALIZE button to open up the window you show in your screenshot.

  2. Then you make your changes.

  3. Then you scroll down and click the SAVE button (as long as all fields are properly set).

  4. Then you’re done.

Where in this process is this breaking down?

Yes, I follow those steps exactly and nothing changes. Maybe it is a bug?

1 Like

Yes, a bug. I am also having issues updating sheet names in bubble that I have renamed in Airtable. It still shows the old name of the sheet and breaks all the dependencies.