Anyone else having issues with data creation/deletion actions not processing all records?

As I’m creating my app, I’m having to import data through an API and then subsequently delete it before retesting the import process.

I’m noticing an issue where the process for both seems to die. For instance, I have a few simple buttons that deletes all records in tables. Occasionally I’m finding that it is not deleting all of the records.

The same is also true for import. Every time the API should import 100 records, but occasionally it stops before all 100 records have been imported.

Has anyone experienced similar issues?


Yes for a couple of days the DELETE isn’t working properly, but I’m waiting to see if other users have the same issue. Have to make some tests because when Delete is the only workflow, it sound to work.

1 Like

I have similar problems, but I deal with many more records, so I suppose it is the quantity that kills it. At the end I decided to have bulk logic outside of Bubble and use Data API calls.

I also noticed that sometimes the development studio “looses” the track and doesn’t show the proper records in the database in App Data. It helps if you refresh the browser.


my app runs extensively on large complex lists… API workflow runs etc. From day dot I’ve seen pretty regular occurrences of delete things not executing… I have remnants of things where only the unique ID is populated. This also goes for the addition of things in a list field on API workflows. With the exception of the creation of a list of things ( although the bulk Data API) is designed for this it won’t work in my case I actually run as much as possible in terms of deletion and modification of things outside of bubble. In my case I have created a raft of .php scripts because it’s easier for me to protect these on a separate server which act as endpoints in turn running Data API’s against my bubble DB

1 Like

I have also experienced similar behaviour on complex API workflows. But it’s not deleting records that fails, it’s more updating fields.

This is one example (not necessarily a complex API) where modifying seems to fail intermittently.

  1. Make API call (get) which returns a list of 10 items in an array.
  2. I create a parent thing (singular) with a list field
  3. I run a scheduled API workflow on the returned array.
  4. For each item in the array I create a child thing.
  5. I add the parent thing to the child thing… Just as a DB field for testing
  6. In that same workflow I then add the child thing to the list of the parent thing

so all in all pretty standard and fairly straightforward. I should end up with a parent thing… With a list field containing 10 child things. Each child thing should have a database field referencing the parenting (just for testing)

Not always the case but in the majority of cases I end up with either 8 or 9 child things in the list field although every child thing contains a reference to the parent thing.

Adding conditions in the workflow to make no difference… There is obviously a link between the 2 items as the child thing always contains the parent thing.

I have gotten around this by doing a search for all child things containing the parent thing and then doing and add to list.

This sounds very similar to the problems I experience, although I don’t have such a simple example case as the one you describe. @emmanuel, can you comment on this one?

I think the best approach if your app is private is to create a bug report and send to bubble. Mine is not in a fit state to do this yet and I need to do a bit more optimisation and make sure I covered all the bases 1st. if we have issues like this without providing a link to the editor we’re not going get much support. I was only commenting in the thread to explain I was having similar challenges

I am also having the same issue when I try to make changes on data on a workflow. Worked before but since a few days, it does not work at all.

This topic was automatically closed after 14 days. New replies are no longer allowed.