API Connector call not listed as action

Hi!

I set up a call as follows:

Clicking on “Initialize call” actually performs the call using the “default” id value of 52 (I can see that the item gets deleted on my server). The plugin reports no error when I do this (when I set an illegal value for the id, it does report an error). This suggests that the plugin regards the call as successful. However, the “Initialize call” link does not go away (I don’t know if it’s supposed to).

When I change to the workflow, the call is not offered as an action:

15

What am I missing?

1 Like

Have you set the app as the test app for the plugin and clicked the button “go to test app”? Also, have you refreshed the app? Hitting CTRL + F5 on your app editor may help.

Thanks for the suggestion! I’m not sure I understand what you mean by “set the app as the test app for the plugin” and I can’t find any “go to test app” button. Can you provide some detailed steps or is there a tutorial of some sort that shows how one does this?

Are you creating a new plugin or just setting API calls inside your app?

I just set up an API call as in the screenshot. I have another API call that is set to “Use as Data” and I can succesfully use it with the Repeating Group. As you can see on the screenshot, the API call that I’m posting about is set to “Use as Action”, but it’s not appearing as a selection in my Workflow.

You can only access it in the Bubble app when you make one successful call and no longer modifies the call, mark the box “capture response headers” then click “initialize call”, then if it works you’ll receive a response and will get that screen that shows every information that came back and if you don’t want any of the information that came back as a response you can choose “ignore” in all of the dropdowns that appear.

If all goes well, the button will then be “modify call” instead of “initialize call”.

3 Likes

Thanks! I would never have guessed it, but the key was - as you suggested - checking “capture response headers” before clicking “initialize call” :grinning:

1 Like

Hello. i have the same problem above, but his solution didn’t work for me.

I have set a API connector, which I can reference on the elements of the Design are, but it doesnt appear on the workflow as a possible action.

1 Like

I am having the same issue as cx1

same issue

I have the same issue. I built another call earlier and using that already. This one is successfully initialized but still not coming up as a new plugin action…

update: I was just temporary blind:) I didn’t set the “Use as” parameter to Action (it was Data). Working fine with the right setup.

10 Likes

Hi @cx1 , did you manage to solve it? I’m struggling with similar issue

this is also “the solution”, not just the (also helpful) post by vini_brito, which I’d summarize as “check ‘capture response headers’”. thanks guys :slightly_smiling_face:

change the “use as” Action not Data

Hey Bubblers,
I’ve a similar issue. I’ve got 3 APIs configured, but only one of them is visible when I try to trigger an API within a workflow.


  1. Are they set to Action rather than data?

  2. Are they initialised?

1 Like

Yes, I’ve set the type to Action and I’ve reinitialized it.
However, only one API is visible in the plugins. Does Bubble restrict users from using more than one API in a workflow?

If that’s true you should see them. Can you show screenshots of each API call? You can hide any API keys

Hey, it does work now :slight_smile:
I tried toggling the data type between JSON and text, and somehow, the APIs magically appeared.
Really appreciate the support!