API CONNECTOR : Content-Type: application/ld+json

Hello all!

I’m stuck with an API I’m trying to connect to.

When I’m trying to initialize the call, I’ve this response error :

The API owner said that is API is working on JSON LD not only JSON

I’ve setup the header according to :

Is someone have a trick for this ?

thanks !!!

1 Like

Have you successfully connected via postman using that header?

What did your body look like?

Hello @jared.gibb !

I didn’t try with Postman. I already connected some other calls successfully to this API, but for this call it seems the “application/json” doesn’t work.

Here’s the json content :

Thanks for trying to help!

Doesn’t look like you need a linked data+json content-type though. With the ld+json I’d expect to see an @symbol prefixing at least on of the json body keys.

Foreal, if I can’t get an api call to go thru in bubble in the first few tries, I resort to postman (or hopscotch.io) as it seems to give me a better picture of what’s going wrong.

okay I m gonna try. Thanks !

the api author confirms that this is a application/ld+json.

On Postman, with a blank content (no parameter) I don’t have the error, I have a 200 response.

Is there something I miss to use it in the api connector @jared.gibb ?

what was the issue / what solved the issue?

in fact it is not solved. The call works great in Postman, but still the same error in Bubble


i don’t see you linking data in your JSON body.

What body are you using in postman? If you are sending something sucessfully, can you try the same hardcoded call in the API connector in bubble. then try it with dynamic data