API Connector POST request problem with content-type plain/text


I’m trying to send a POST request with API Connector to an external API and the only accepted Content-Type is text/plain along with charset information (charset=UTF-8).
I specified in the shared headers but when I try to initalize the request I have an error 405 Method Not Allowed telling that it’s an invalid request method POST (screenshots below).

When I try the request on my Postman, it works perfectly (screenshots below).

Can you tell me if I miss a step somewhere or if it’s a bug, please?

Can you share headers in postman? Also, according to postman result, the data type will be json (this field is for the response)

1 Like

Thanks for your reply. What do you mean by ‘share headers’? You mean like on Bubble with the shared headers? If so I don’t think you can. But I also try without sharing headers and put the headers directly in the request, I get the same error. I also tried with the data type JSON but it changes nothing.

In Postman, can you select the headers tabs and post a screenshot. Post screenshot also of headers you have in Bubble

Postman headers

Bubble headers


On the Headers add Content-Type = text/plain also change Data Type to json


Hi Amos,

Thanks for your reply. As you can see in my last capture above, I also tried to initialize with the data type set to JSON and with the headers inside the request.

Also I tried a request GET for this API and it works perfectly on Bubble and another request POST with content-type text/csv and it also works perfectly.

It is advisable to delete the api call and create it afresh sometime if you have progressively changed it.

1 Like

Also, send url to API Doc, that can help

Alright. Thank you both for your answers. I have deleted the API call and create a new one, I get the same error. Please find below screenshots of the API doc for this request.