Appointment time settings is not correct in email

Hi everyone,

Another one met the same problem like me but no one can’t help to solve it.

When I use a workflow to send my meeting request, the user can’t receive the email with the correct time formatted in the current time zone. In my case when the time is “10:00”, the time in the email received by the user is: “11:00”. Date/Time picker is formatted well.

As you can see below, in my workflow I can’t format the start time filed of the workflow “Send meeting request”.

16

How to fix this?

Is it impossible?

Thanks for your help. :wink:

I’m not at my computer, but it is a solvable problem. I struggled with this greatly as well, and had to end up writing my own program to solve it.
What’s happening is that Bubble, on the server side, stores times in UTC. That’s why the time you’re getting back is different. A few ways to skin this cat:

  1. there are a few plugins that might help, https://bubble.io/plugin/date-time-converter-1525169938981x125356287341625340 from zerocode comes to mind although I haven’t used for this use case
  2. write a function like I did that takes in a UTC Unix timestamp and certain parameters you need for scheduling, that returns the time you want. I needed to do this in my case because I’m scheduling thousands of events a day across the world all with different parameters
  3. let the user know they’re seeing the time in UTC. Some people just want to see the world burn.

Hi @scott3. Thanks for helping.

Can you explain step-by-step please? I’m a newbe. How do you write that funtion with the parameters?

Thanks :wink:

That’s pretty complicated and I’m in the Colombian mountains at the moment not at my computer, I’m considering creating a plugin for scheduling but it’s not a good option for you to wait for it… I’d suggest using the Zerocode plugin, or grabbing a 30 minute session with cobubble to get you past it, as it seems to be a display issue only (the date is stored correctly, just in a different time zone).
Greetings from Valle de Cocora!

This topic was automatically closed after 70 days. New replies are no longer allowed.