Automatically enter current user’s location

How would I be able to enter a current user’s geographic location into an input once they allow access to their current location?

Double click on the Default Value and select > Current geographic position

Hope that helps !

Cheers.

3 Likes

When I pressed preview, I saw an “inspect” error saying “User Denied Geolocation”. Also, when I navigated to the screen with the location input, there was no default value and my browser did not ask “Allow website access to current location?”. Any idea on what happened?

Click on Editor > search box, choices styles > geographic places, and in default near the bottom, there is Current geographic position.

It would seem that your browser is not letting the location information to be shared.

Try to find a setting in your browser that would allow you to change this. Or maybe just reset all the settings in the browser.

Maybe try a different browser. :thinking:

Thanks!

This topic was automatically closed after 70 days. New replies are no longer allowed.

Hey guys,

Thanks for this post.
I managed to get the current location of the user by using Current Geographic Position:extract City.
The problem is that on mobile browser or webview it won’t work.
Even if in the wbview I gave it instructions to ask for permission, or in native browser safari or even chrome, it will not populate the field with the city.
Can anyone help please?

So this ius my workflow.
Am I doing something wrong?
The mobile app asks for location permission from my app’s name, and then from the url on bubble.is.
Accept both bot the location is not changed…

NEVERMIND!
Thank God it doesn’t hurt when you are stupid… otherwise I would’ve been in a lot of pain until now.
So the template I bought had different forms for mobile: 1 for portrait and one for landscape…
So this is why on desktop and tablet it worked and on mobile didn’t.
STILL, I have one more question:
Why on :extract City it gives me Antarctica, and when I use Country instead of City, it prompts with City,Country ?

nobody is experiencing the antartica at city? Country works fine, but City doesn’t

That’s a pretty big city :slight_smile:

But no, maybe if you could share a link to your app editor ?

1 Like

Sent you a PM.
I will post the solution here. Not that comfortable of sharing the entire app with everyone :slight_smile:

Hi @mvandrei, how exactly did you get the currentGeoGraphic position on a mobile device to work in the end?

I’m experiencing the exact problem right now but when you say “So the template I bought had different forms for mobile…” I don’t understand what you mean… I see no options/templates or anything like that anywhere. Is there something that needs switching on to get this to work on mobile devices?

Bit confused :confused:

It’s ok, I think the problem may be due to the fact I’m using the development “preview” URL to test with on a mobile which is running as http and not https. @NigelG I see your post a few months ago about Google not allowing for location services if not on a secure site. Can I ask, when I finally push everything Live, will the link become https making it work?

hi i am having same probelm
did u fix it
if u did can u plz tell me how u fix it?

@vamosjaha don’t quote me on this because I can’t remember now exactly how I fixed it, but… I think I did it through the Google Domain section which controls my DSN and somewhere in there I muts have enabled an option to make it work on https… like I said not 100% on that but I’m sure that’s where you need to look first (if Google host your site that is) - failing that, you might get lucky and someone will correct me if I’m wrong!

Good luck :slight_smile:

Still you need to have Google Map API keys?