Ayrshare Plugin and image URL's

Hi again, Great Bubble Gurus!

I am using the @ayrshare plugin to send social media posts directly from my app but having an issue. Once the post gets to Ayrshare, it complains that the image URL does not start with “https://”. My URL’s all start with “s3.”. Can anyone elaborate on why my image URL’s are this way, and how to make it compliant with Ayrshare’s requirements?


1 Like

Hey Curtis,

When you upload to AWS S3 via Bubble, all the URLs start with " //s3.amazonaws.com" and are missing the protocol of http(s).

There are two ways to handle this.

  1. You can add the https yourself. Here is a post discussing how: How can I add "https:" to a file's URL?
  2. To made life simpler, Ayrshare now automatically adds an “https” if the url starts with “//”. So you should now be able to post to your social media networks without an issue.


Hi Geoff! Thanks for your response. I tried the workflow as recently as 2 hours ago, was that change made since then? Here is what I’m seeing in Ayrshare:

I’ll try option 1 and follow up with results. Thanks again!

It was just changed, so give it another try. You should now be able to directly post the images - sending them in the media_urls parameter.

Yep, just tried again without changing anything and it worked. I love when problems fix themselves! :slight_smile:

Thanks so much, looking forward to using this plugin on my production app.

1 Like

This topic was automatically closed after 70 days. New replies are no longer allowed.