Background Video in Firefox


I am having issues with background video in firefox, I only get a black screen.

Hi @boston85719 :slight_smile: Is the video not playing at all? I know that Firefox blocks autoplay videos that aren’t muted, but if your video doesn’t have sound there may be a Firefox setting turned on that is blocking all autoplay videos?

@fayewatson There is no video playing at all. Another issue is that the Fallback image doesn’t show either. All I get is a black background.

I checked the settings

And it seems to be set up the correct way. I am also able to see on other sites their videos playing automatically, so it doens’t seem to be an issue with firefox or the settings.

Not really sure what else it could be. I have the option to be muted playback checked in the bubble editor as well.

Hmm, that’s odd! If it’s helpful I can definitely test on Firefox on my computer to see if it doesn’t play there as well?

That could be helpful…I created a new app and it doesn’t work on the new app either, so I shared a link to the new app

It is editable, in case that helps to figure out what the bug is.

Hi @boston85719 :slight_smile: Sorry for the delay! I just tested on Firefox and it’s playing correctly for me there. Do you have any adblockers installed for Firefox? That may be blocking the video. If not, uninstalling and reinstalling Firefox might make a difference?

Thanks for taking a look at it. I just tried again with an adblock turned off and it still doesn’t work. The strange thing is that I don’t think it has to do with the browser because on other sites I am able to see video fine…the idea actually came from seeing about 30 different site designs using background videos.

I also have some other buggy type of issues with it.

  1. I would assume if there was an adblock causing the video to not playback that the “fallback image” would be displayed instead; this is not the case for me, I get only a black screen.

  2. When I have the checkbox play on silent checked

In the debugger mode it shows that Play video silent is a no

If I go into the editor and uncheck the box and then check it again, in the debugger mode the play video silent will show yes. However, when closing the browser and opening again the same issue occurs, debugger shows no despite the fact the checkbox is checked in editor.

I know in the past there were issues with this, that seemed to have been resolved. It was the same issue.

I feel like something might not be working as it is supposed to. I would feel a lot better if the fallback image was at least being displayed.

No problem! :slight_smile: Right, it definitely sounds like there may be a bug! The fallback image is only displayed when the page is loaded on mobile (to prevent the video from using mobile data), but the fallback image isn’t shown if the video isn’t playing. Just to double-check, do you have flash enabled in Firefox?

I just installed the flash player. Closed out the browser and after reopening with flash player installed, it still doesn’t work.

Did you click ‘Allow’ for the site?

I just set flash player to always activate…works now! Thank you so much for the help. These types of things I’d never be able to figure out on my own.

By the way, do you know if there is some method to ensure an image is displayed when a user doesn’t have flash installed or disabled? I would assume it would be a huge design issue if they couldn’t see the video or an image of some kind.

Awesome! :slight_smile: No problem at all! And I totally understand – It’s very tricky to debug these and see if it’s a Bubble issue or some other small detail! So glad to hear it’s working now!

I’m not sure of the best way to set this up; I took a quick look at Stack Overflow and it sounds like it’s possible though! :slight_smile:

Thank you. My assumption is by the implication of looking on Stack Overflow, it is not a possibility in Bubble but would need some kind of code.

I am starting to get into some basics of javascript and css to try to make use of the toolbox plugin and csstools as well. Probably in several months time I will have picked up enough to find my way around. For now will continue to try and implement as much as possible without code.


1 Like

This topic was automatically closed after 14 days. New replies are no longer allowed.