[Breaking Change] Inputs with a number format now take a number as initial content

I havent updated to the new version yet and i see its affecting my app. numbers display dont work as should.

@Bubble you guys have to check out these things before deploying. People are using bubble for real life applications. Except you want us all to just use it for our hobbies.

Hello folks! If you’re seeing issues with the new version, please do file bug reports so that our team can investigate. If you haven’t updated to the new version, you should not be seeing any impact, so issues are unlikely to be related specifically to the version.


@adunniola I was also concerned about the display but another update earlier today added the option to set decimal places. Maybe this will help…


1 Like

Is this new option a set decimal place? Example. Decimal =1 means 1 = 1.0

The old decimal place selector was a max decimal place. So while 1.23 was 1.2 1.0 was 1, not 1.0

Using it now, it is a set number of decimals. If you set it to 2 decimals, 1.2 becomes 1.20.

1 Like

Excellent. Thank you @chris.charette241

I had that work yesterday, but today it is no longer working in my DB. Errors came back. Red everywhere.

I just submitted one. If you guys come up with some good solutions, it would be great to have an explainer video recorded to show us common workarounds. I’m unable to push updates to my live instance while we wait.

Hey @josh10,

You can always revert back to Version 11 while they work on a fix for the issue.

1 Like

Still hanging back. Not a nice update…

My recent experience is different. Some of the recent made on inputs that have numbers or number like values already affects those who are even still on the old version.
Especially on decimals and percentages.
Before now, the percentage was used for display purposes. Now, its applied as an actual percentage value.

Example. I had an input value that is set to percentage. to use it in a calculation, i had to divide by 100. I just tried it now and it multiplies as a percentage and not a number.

Now i have to go back and check every formula that has this feature and change the formula.

Now this is a very welcome development as it reduces complications on formulas, but you have to let us know that it affects all versions. If i wasnt in the middle of testing i wouldn’t know and my users would be churning out wrong numbers if i pushed to live without making these changes.

One other thing I’ve noticed about the latest upgrade is how slow the overall editing session is. I have two windows open at all times now, one with issues=true and one with issue=false but the false windows is just as bad as the true window. It makes the entire editing session close to unbearable.

I’ve tried clearing cache, and I use a combination of browsers, but I’m still feeling the effects of a very slow session. Bandwidth and PC capacity are also not an issue as I have scads of both.

This part is helpful @cal I’ve just done a search on my app and for number, I’m seeing 23 things for number alone. This seems like a really problematic break for my app so I’m thinking of holding off on the update.

Second thing is, what am I changing the input to? Is this supposed to be every one of these things that has the content format as a “text (numbers only)” will need to be changed to integer, currency, etc?

@cal hoping you can provide some input on the second thing above.

Thank you!

not sure if this helps anyone but I just added :product to the end of my expression and the errors went away. Not sure if I am creating another issue down the road.

1 Like

Has anyone else experienced the “We just updated this page” alert when nothing has changed. I often see it within a minute after refreshing the page from a real change…almost like it didn’t refresh everything and if figures it out a few seconds after the page is loaded forcing me to refresh again.

This happens for me a few times a day. Since I’m actively updating a lot, and the refresh can take a painfully long time when you’re in a hurry, a few additional refreshes just frustrates the development process unnecessarily.

1 Like

I upgraded to V12 without realising, now when I have gone on to Development mode it throws up 4,275 errors from across my pages (over 250 errors per page). I have a financial app, so this is very frustrating and has completely ruined my app - I will not be changing each inputs formatting.

Therefore could someone please show me how to go back to version 11 of Bubble? @cal

Like various people here, I used the “formatted” as to display for example 7.25%
I have reverted to Version 11 as I had many errors and am waiting to hear if “rounded to” will fix the way I want my numbers formatted

Please add a feature to make it easy to merge templates.

I think some kind of auto correction is working behind the scene now. I could successfully upgrade to this version by just tapping on the alerts, it magically removed the errors. Thanks always bubble team!

1 Like