Bubble bug on 200 DB rows?


I have just created a brand new app with Canvas template. There were 79 rows in the DB. Then I added a Log data type and 1 Data field. And suddenly I was asked to upgrade because 1397 rows is used.

Here is the editor link.

Canvas template takes 79 rows, less than 200 rows. There are many people doing the Airdev bootcamp using the Canvas template without problem. What is going on?

@net-tt, you should definitely submit a bug report if you haven’t done so already because I looked at the editor, and as you already know, that 1397 number doesn’t seem right at all.

Just out of curiosity, are you able to create new things in any of the data types? In other words, does the fact that it thinks you have 1397 rows in your database actually stop you from creating new things or is it just a display issue on the Settings tab?

I can’t add any data.

A page with a button that just adds current time to the Data field in Log data type.

I will submit a bug report.

Under Settings → General tab, try doing Optimize app as well as Clear app changes history

Then probably more likely to help is under the Data → App data - > Copy and restore database

At the bottom of the popup you can clear all database history, maybe it’s some “deleted” items still there…

The 200 thing limit is across all datatypes, have you checked each one for existing database things?

This is a new app created with Canvas template, which comes with some very limited data set. When I added 1 data type (Log) and just 1 field (Data), the upgrade warning showed up, so I just stopped adding more fields. There is no data that can be cleaned as I have not added any data.

I’m just saying maybe their template has some hidden/deleted database items, IDK

When I just create an app with the template, there are only 79 rows. After I add a data type and 1 field, it jumps to 1397 rows. It happens to 2 apps.

Here is the DB usage after the initial creation.

Strange… yep definitely do a bug report

This topic was automatically closed after 14 days. New replies are no longer allowed.