Bubble.io AWS Cognito OAuth 2.0 Integration

Hi everyone!

We use Bubble.io for the frontend on our project and AWS Services fog DB and business logic. In this case, we need to Sign up and Sign in users in Cogito AWS.

The best case, which we want is:

  1. User filed “E-mail” and “Password” fields on Bubble.io page and click the button “Sign up”;
  2. We create a new user in AWS Cognito pool;
  3. User logged In to Bubble.io with AWS Cognito pool permissions.

If we can’t do this, I think about another case (OAuth 2.0):

  1. User clicks the button “Sign up” on Bubble.io page and redirects to UI AWS Cognito form;
  2. User create an account on this form;
  3. User redirects back to the Bubble.io with AWS Cognito pool permissions

So, I have a problem with integrating Bubble.io with AWS Cognito. You can see my Cognito AWS application settings:

Also, it’s my API connector Bubble.io settings:

User click button with one step:

User redirecting to AWS Cognito (this user already exist in Cognito):

And when the User click Sign in button in Cognito UI, redirecting back to Bubble.io page, but with an error “missing access_token”.

BUT! I see this token in the console:

Do you have any ideas, about what went wrong?

Read the warning under all of your configurations in the API connector. With oAuth you need to test the API first in run mode or it’ll fail like that. i.e. with the page parameter debug_mode=true

See whether that solves your issue.

But I can tell you that I had worked with AWS Cognito on another project (not related with Bubble) and I found it to be one of the most antiquated and annoying authentication services I’ve ever used. I still have nightmares about it haha.

Josh @ Support Dept
Helping no-code founders get unstuck fast :rocket:save hours, & ship faster with an expert :man_technologist: on-demand

Hi @josh24!

Thank you for you response, but with ?debug_mode=true I have a similar result (

Hmmm. I’m not sure I’m afraid.

Josh @ Support Dept
Helping no-code founders get unstuck fast :rocket:save hours, & ship faster with an expert :man_technologist: on-demand

This is crazy I am literally trying to figure out the same thing today.

1 Like

Change the user endpoint to https://<your-user-pool-domain> /oauth2/userInfo

@mihir.umarye I tried with “https://<your-user-pool-domain> /oauth2/userInfo” but I still have the error mention by @Frinet

I just succeed ! Enjoy guys