Forum Academy Marketplace Showcase Pricing Features

Button not clickable in Repeating group

Hi everyone,

I have a repeating group displaying all the information regarding one storage place of a company (Location, certifications, Cut off time, and many other inputs). All this information sits in a group (Group Warehouse) inside the RG row and has a custom state (yes/no). I created a button (Button Edit) inside the “Group Warehouse” to allow the user to edit the information in it.

This works in the workflow as “when button edit is clicked” – “set state of Group warehouse to yes”. Then there is a conditional in every input field, that if the custom state is yes, then the input fields are enabled.

The funny (not so funny anymore) thing is that I have the exact same workflow in another group in the same app but this one inside the RG is not working. I tried bringing the button to the front, deleting, and recreating the workflow from scratch, but I can’t figure out why my button is not working. PS: my button is clickable :sweat_smile:

I’ll attach some screenshots


image
image

and thank you in advance!

When you say it’s not clickable, do you mean it’s actually not clickable (i.e. the mouse pointer doesn’t change to a finger icon)?

Or just that the workflow is not running when it’s clicked?

Hi @adamhholmes
thanks for the quick reply, and the great question, it is actually clickable, so the mouse pointer changes when hovering, but the workflow is not running properly

Just curious if you tried something like what I suggested in your other thread.

Hi @mikeloc

I actually did last time and this one, and unfortunately, it does not solve the problem :frowning:

1 Like

In that case the first thing I’d do is use the debugger to see what’s going on…

(although, as @mikeloc alludes to, I suspect it’s to do with having more than one workflow on the same button click, and not having the right conditions set on those)…

But the debugger will tell you what the issue is (if you know how to use it)…

2 Likes

Don’t know, but this don’t seems right to me

image

You have two workflows being triggereds when “Buttone Edit Warehouse” is clicked.

The first workflow, will be triggered everytime (as it do not depends of any condition).
The second workflow, only when your custom state is YES.

3 Likes

Hi!

You can’t change the state of a group in an RG that way.

U can use a plugin like List Shifter: Reverse, Rotate, Swap and ITERATE (Loop) Over Bubble Lists | Now at v1.4: Adds Numeric Option, GET INDEX Action which has a built in “selected cell” feature and then use that to trigger a workflow to enable editing.

A native way is to actually have a state (number type) in your page that will be used to store a cell’s index.

So when the user clicks Edit, your workflow will store the ‘cell’s index’ in that state.

Now all u have to do is set your conditionals to enable editing when “cell index is state”.

Yup, @rpetribu… that’s what didn’t seem right to me 15 days ago. :slight_smile:

1 Like

I also suspect it has something to do with the workflows but not entirely on having different workflows for the same button. I learned those conditionals in a bubble course I did a while back. I attach a screenshot of the app I did in the course… the assignment was similar:

Post comments and display them in an RG, also have the ability to edit the comment if you were the comment creator, or display a message (message: “you cannot edit this”) if the user was not the creator. The only difference is that in the assignment I did it with an icon and not a button
image

I wrote this post like 20 min ago and forgot to submit it. I will read now your proposal carefully @ihsanzainal84

Yeah, those two workflows make sense (kind of), as they have the opposite conditions, so only one of them will run when the button is clicked…

The workflows in your app, however, (the ones in your screenshot in this post) don’t make much sense, as only one of them has conditions, meaning that in some cases they will both run, which is almost certainly the cause of your problem (but again, the debugger will show that more clearly).

For what it’s worth, @dafne.sinopoli, you can do what you are trying to do, and you don’t need a plugin to do it. I made a quick example that mimics what you described, and these workflows work as expected.

The only difference I can see between my example and your setup is that I set the default value of the custom state to no, and the default value on your custom state is empty. That being said, I did a test where I cleared out my custom state’s default value and I removed the Only when condition from the first workflow, and it still seems to work.

So, long story short, you should definitely check out the debugger like Adam said, and if you are willing to share a read-only link to your editor so we can take a look under the hood, I’m guessing we can figure out what’s going on.

1 Like

Hi @mikeloc thank you for taking the time and recreating the workflow. I will give it a try again with the two conditionals (one for CS = no, and CS = yes). My question would be, in your example did you recreate it in a repeating group or just a group?

Thanks again,

I used a repeating group in my example.

1 Like

I gave it a try, and set the conditionals in the workflow as suggested, but still somehow is not working. I believe is something with a condition not being met.

Here is the link for the editor, maybe a fresh pair of eyes can see what’s going on

Something strange going on there… I’m guessing it’s a bug (the debugger is not even recognising the button click)…

The only thing I can suggest is to try deleting the worklfows and recreating them (I’ve heard that can sometimes fix weird bugs like this)…

If that doesn’t work then I’d submit a bug report or contact Bubble support.

1 Like

I think I found a potential solution or workaround to the problem, because as you mention it might be a bug, but I cannot trust bubble to not do it again (it has happened to me already a couple of times that I do something by the book, and it doesn’t work)

I created a testing page to check if it works and although it does not look pretty it does the job, and I will have to solve the “prettiness” at some other time.

What I did was take the “Edit” button out of the input group, but still inside the RG row, and keep the workflow as it was (with the two conditions as suggested). This way when I click the button, the inline editor is available for the user to modify the information and save it when finished. I also plan to add a delete button with the same logic and hope for the best

Thank you both for the help, if you think of something else that might work, let me know. I will anyways submit a bug report to bubble

2 Likes