Button not working in repeating group

Weird thing that’s happening, or a bug. Not sure if I’m doing something wrong or not.

But I have a repeating group, and I have put a button in each, but for some reason it’s not detected and can’t be clicked through both in preview and live. I want the button in each cell to close the repeating group and open another group/repeating group.

I tried changing it from a button to a text that can be clicked and have a workflow too, but no luck. Simply nothing in the repeating group will be detected as a clickable object. I tried lots of different workflows to see if that was the specific call and nothing works.

This is the workflow I’m trying to do. Is it a problem with this? It should be detected still as a clickable object right?

No idea what’s going on here.

In the debug flow, can you tell that the element is actually getting clicked? There may be something covering it that’s preventing it from getting clicked. I’d go into “step by step” mode to see if anything is actually happening.

1 Like

Thanks for responding Andrew.

In the debug, step by step, when I click it nothing happens.

I’ve tried arranging it by sending to front, still nothing.

Are you certain your workflow is connected to the correct button? In other words, in the editor when you right click on the button and select ‘Start/Edit Workflow’ are you taken to the workflow you show above?

Yep, 100%

I’m a relative newbie but I’m happy to take a look if you’re happy to share access.

Without a link to the editor, this is going to be impossible to diagnose. If you can share a link to your editor, with the permissions set to “anyone can view,” that’d be the easiest way forward.

Still got nowhere with this, driving me mental.

It’s on the mobileregister page - Group Contest History, Repeating Group Upcoming and the Follow button - https://bubble.io/page?version=test&type=page&name=mobileregister&id=cryptobettr&tab=tabs-1

SO I managed to get the button kind of working - it now works when I move the Display data to the second part of the workflow, however, it only actually does one part of the workflow in hiding an element.

In the debugger, I’m running step by step and it says it’s displaying elements, shows no red flags, but nothing actually is showing.

This topic was automatically closed after 70 days. New replies are no longer allowed.