Button with a Condition

I have a button that becomes visible based on a condition. Sometimes when the condition is true, the button does not appear, but the hyperlink where the button should be is active.

In other words, when the condition is true, the button is not visible, but if the user clicks where the button should be, the workflow is triggered.

Any idea what is causing this?

Never saw this kind of bug.
Invisible elements can not be clicked. So this is odd…

Can you share a video or images of your editor?
Something is wrong :sweat_smile:

Hey Curtis,

Welcome back to the forum! Agree with @rpetribu here

That’s weird but try adding a condition where if element is not visible, this element is not clickable.

Here’s the condition:

Here is a screen shot of the input.

Here’s a Loom link that shows my mouse pointer as I hover over where the button should be visible.

Yeah, it’s look like a bug…

Do you have any other conditional formatting in this button? Or any workflow that may be interfering in this behavior?

Do you mind to share your editor so we can check what can be causing this issue?

Yeah, you are right! This should really work, but I think the right/best thing to do is to try to understand what is happening.

1 Like

Hi rpetribu,

I’m not sure what you mean when you say “share your editor”. I’d be glad to share it…just don’t know how.

@curtis1 , here :point_down:

And after it, share the link with us…

Didn’t know that was possible!

I changed that setting and here is the link. bulldogscores | Bubble Editor


@rpetribu :point_up_2:

Hi @curtis1 !

I tried to check it out but the visibility of the element “Group Data Entry”, which contains the button depends of your database records, which I can’t edit.

Anyway, I reproduced your setup in my app (with old and new responsive engine) and I didn’t have this issue. Everything worked well.

I advise you to delete and recreate this button to see if the problem disappears. If not, I suggest you to fill a bug report.

And remember to change your App back to “Private App”.

delete the button and create a new one, I already had it with popup. This is the quickest thing to do than thinking about the cause, it could be a browser, it could be some condition that you don’t know where you entered. Better to redo, that’s good learn twice. Good luck.