Forum Academy Marketplace Showcase Pricing Features

Button not working- how to find out why?

I have a button that creates an thing that only works sometimes. The standard “this input should not be empty” aside, other variables seem to be making it unclickable but I can’t find out why.

Any ideas how to detect this? Using the “run step-by-step” doesn’t help as it’s just plain old unclickable.

Run preview from the Editor, make sure debug_mode=true in URL. Then change to step by step, you will then see the actions or in your case the reason why it is not working

That’s what I meant but it doesn’t do anything with step by step. No event happens because it is unclickable.

Have you checked the conditions,

A good test is add another button and compare the settings

This is so weird.
For conditions, there are no conditions affecting whether it is clickable.
There are, however, 3 “this input should not be empty” spots.

I copied the button and removed the workflow attached except the animations to know it worked. It looks like it has something to do with the workflow blocking it as the one without workflows works once those 3 fields are filled.

Managed to narrow it down to one specific condition through testing. Now working to find the bug there.

Hi :smiley: can you share pictures of the button conditionals, and your workflow?

May sound very obvious but you checked in the button "this element isn’t clickable? or in some of the conditionals?

Or maybe some group, shape, or other elements is overlaping with this button when the page is stretched or collapsed ?

Bests,

Juan

So I had 37 variables being added in that one condition that created a thing… so I did some good old trial and error. Identified the at fault input. Then after while noticed that it was set higher than its maximum in ALMOST all cases. Which is why it only sometimes worked, seemingly unpredictably.

Thanks for the ideas on looking through the workflows!

1 Like