Forum Academy Marketplace Showcase Pricing Features

Can Optionsets be filtered?

Hey all,

Having trouble filtering option-set data. Not sure what the issue is. Might be helpful is a layout my current process.

  1. Under my data type “Job” I have a field called “Job Types”. This field is an option set for the different types of jobs each job can have (Full-time, Part-time, Internship, etc).

  2. I’ve created a drop-down that is connected to this option-set (Job Type). The goal is to allow users to filter their search based on options in the drop-down.
    Screen Shot 2021-07-06 at 11.14.27 PM

  3. To allow the user to filter, I have created a workflow that filters search results based on the drop-down changes (when user selects different options). I then try to filter the job value based on the drop-downs value. However, it does not allow me the drop-down’s value.

Based on the process above, it would seem that I am unable to filter option-sets for some reason.
Has anyone ran into this problem before?

Hi @brandon6 - I was able to replicate what you are trying to do with Option Sets.

I see 2 differences in filtering rules between our approaches. I was able to do that with a ‘Do a Search for Jobs’ (without :filtered) and add the constraint as ‘Job Type = This Dropdown’s Value’ (instead of ‘This Dropdown’s value’s Display’).

  • I think the reason for the error on your filter is that ‘job type’ is probably an object from Option Set and not a text.

Please try this and see if it works for you.

1 Like

Thanks so much for the response.

Yes, it currently is an optionset. Does it need to be text for me to filter?
I’m still unable to set the Job Type to the dropdowns value.

No, you don’t need to change the filter to text. (Only when you are using This Dropdown’s Value’s Display, then it has to be text). But we can use the OptionSet directly, as I was able to do as well.

I can’t think of anything else that can go wrong. Are the drop-down value settings configured correctly - like dynamic choices, with source as Job Type (& not static choice)?

1 Like

Hey partha,

I appreciate you working with me to figure this out.

Thankfully the issue is now solved. To be honest I’m not sure what fixed it, i played around with many different options (kinda disappointing). I believe it was the load state that was the issue. I think I had the custom state set to the wrong thing.

Anyways, thanks for your help!

Yes, sometimes that happens - like getting resolved without knowing the actual root cause. However, I am glad, you were able to resolve that.

1 Like

This topic was automatically closed after 70 days. New replies are no longer allowed.