Forum Academy Marketplace Showcase Pricing Features

Cannot Search Number Field in Search Box

Have a field where we generate inventory #'s - originally it was a text field, but we realized as a text field our data was not sorting correctly and a search box had to be exact (comma for thousands separator).

Just got finished, changed text field to number field, reloading all new data into live version, fixed all inputs and workflows to match new field, only to find out a number field IS NOT an option in “field to search” in a search box.

Ugh…am I missing something? Any ideas on how I can allow a user to search my database based off a number field.

Thank you.

Do you have a screenshot of the specific portion that is causing this? Can you show where you are trying to set the field that is not available?

Also found that in the Reference guide it specifically says this searches text fields and not any other - so it maybe a feature request to get it to search numbers…

Field to search
When picking a dynamic source of entries, you’ll need to define which field will contain the texts that can be used for autocompletion. You do this in the ‘Field to search’ property. For instance, let’s say you want to display restaurants in the Search Box, you’ll probably set the list of options as a ‘Search for restaurants’, and will pick ‘Name’ as the field to search.

@john3 yeah that’s what I figured - Pic below… “QP #” is the old text field, I made a new number field called “QP”…as you can see its not an option:

@emmanuel - is it possible to request that number fields have the ability to be searched in a search box?

You could always store the text representation of the number as well as the number if you want to search.

Because in number terms … 1 is … well. … 1. It isn’t 11 or 111 or 1111. That is a text function, not a numeric function, to say if the first character is 1.

@NigelG - I did have that at first, and it worked somewhat for search - an exact example from my program was this - if I was searching for number 11.817 - I would begin to start typing and autopop list would begin to display numbers starting with 11 - but 11,817 would not show up until I put the “,” (comma) in.

The other issue I was having - was sorting the numbers in a repeating list. They would sort in chunks chronologically, but the list as a whole would not sort chronologically. The minute I changed to a number field - this issue was corrected immediately.

Yeah, that’s annoying with the comma. I wonder if it is possible to store it without.

1 Like

Yeah - I’m wondering now if I were to convert everything to a number without the comma in excel, then re-upload everything into a text field if that might solve it.

Found a work field work around now, may end up working better for our purposes - looking up by the units serial # rather then our internally generated #.

Always appreciate your help @NigelG. Thank you.

1 Like