Forum Academy Marketplace Showcase Pricing Features

Cant find Data Type in Zapier

No Data Type in Zapier. Any suggestions?

Hey there @novickiy.digital,

Have you tried to click “Load More?”

Having this same issue, load more is greyed out

I’m trying to use this and having the same issue too. They are connected and I can see my App and dev version of but no data types showing. My data from the Bubble API is definitely working too as I can access that from elsewhere.

Hey there @richard16,

Just a quick check. Are you on a paid plan?

Yes, this project is on the professional plan. I can also access the projects API using reqbin (which I always use for API testing) and Zapier is connected ok and can see the account, and project, just no data types within it :man_shrugging:

Hey there @richard16,

Have you enabled the Bubble Data API?

Yes, and I can access it from other services (e.g. reqbin) with no issue so I’m sure the API itself is fine. It seems to be the Zapier connector imo

Hmm. Alright. Have you tried to file a bug report, for the Bubble Success Team to take a look?

Funnily enough, I just went to do that and get some screengrabs to show the issue. Today it appears to be working fine! :man_shrugging:

Though annoyingly, my next issue is that all fields from a user table are shown apart from “email” for some reason. And of course, that’s the field I need to look for to check if a user exists before creating one…

Hi Richard, did you manage to figure this out? I am having the same issue.

I thought I had figured it out by adding in another section in my Zapier flow, which worked to show me the user details, however, it doesn’t show as an active Zap in the plugin details. This is so frustrating!

Unfortunately, not within Zapier as I couldn’t access the “email” field to determine if that user already existed. The way I solved it wasn’t pretty but works! Basically, I add all my orders to a temp database within Bubble. Then within Bubble I either add an order to an existing user, or create them first if they don’t exist and then add the order to that new account.

Thanks for the reply Richard.

I solved it not much longer after messaging you.

In Zapier I added another Bubble step (after the first Bubble step), I used the search function which allows you to search for user. I searched for the ID of the thing I created.

This unlocked all of the User data for me (including email :slight_smile: )

Hope that might help you.

Great news you got sorted :+1: